POJ2488:A Knight's Journey(DFS)

Time Limit: 1000MS
Memory Limit: 65536K


Description

Background

The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans?

这里写图片描述

Problem

Find a path such that the knight visits every square once. The knight can start and end on any square of the board.

Input

The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, … , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, …

Output

The output for every scenario begins with a line containing “Scenario #i:”, where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number.

If no such path exist, you should output impossible on a single line.

Sample Input

3
1 1
2 3
4 3

Sample Output

Scenario #1:
A1

Scenario #2:
impossible

Scenario #3:
A1B3C1A2B4C2A3B1C3A4B2C4

Source

TUD Programming Contest 2005, Darmstadt, Germany


解题分析

遍历棋盘、打印路径:基础深搜题。

观察打印顺序可以发现,八种移动方式要按在棋盘上从左到右、从上到下的顺序遍历。

每次搜索先记录路径,否则最后一步不会被记录。

越界、已被访问的点,或已经遍历成功都不应继续搜索,因为会覆盖路径。


AC代码

#include<iostream>
using namespace std;

int Visited[10][10];
int Path[85][2];
int MoveMod[8][2]={{-1,-2},{1,-2},{-2,-1},{2,-1},{-2,1},{2,1},{-1,2},{1,2}};
int p,q;
int SucFlag;

void DFS(int r,int c,int Steps)
{
    Path[Steps][0]=r;
    Path[Steps][1]=c;
    if(Steps==p*q){
        SucFlag=1;
        return;
    }
    for(int i=0;i<8;i++){
        int x=r+MoveMod[i][0];
        int y=c+MoveMod[i][1];
        if(x<1||x>p||y<1||y>q||Visited[x][y]||SucFlag)
            continue;
        Visited[x][y]=1;
        DFS(x,y,Steps+1);
        Visited[x][y]=0;
    }
}

int main()
{
    int T;
    cin>>T;
    for(int t=1;t<=T;t++){
        cin>>p>>q;
        for(int i=1;i<=p;i++)
            for(int j=1;j<=q;j++)
                Visited[i][j]=0;
        for(int i=1;i<=p*q;i++){
            Path[i][0]=0;
            Path[i][1]=0;
        }
        SucFlag=0;
        Visited[1][1]=1;
        DFS(1,1,1);
        if(SucFlag==1){
            cout<<"Scenario #"<<t<<':'<<endl;
            for(int i=1;i<=p*q;i++)
                cout<<char(Path[i][1]-1+'A')<<Path[i][0];
            cout<<endl<<endl;
        }
        else{
            cout<<"Scenario #"<<t<<':'<<endl;
            cout<<"impossible"<<endl<<endl;
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/Hrbust_cx/article/details/78156874