POJ-2488 A Knight's Journey (DFS)

A Knight's Journey
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 40609   Accepted: 13800

Description

Background
The  knight (骑士) is getting bored of seeing the same black and white squares again and again and has decided to make a journey
around the world. Whenever a knight moves, it is two squares in one direction and one square  perpendicular (垂线) to this. The world of a knight is the  chessboard (棋盘)he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still  rectangular (矩形的). Can you help this adventurous (爱冒险的) knight to make travel plans?

Problem
Find a path such that the  knight (骑士) visits every square once. The knight can start and end on any square of the board.

Input

The  input (投入) begins with a  positive (积极的)  integer (整数) n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q  chessboard (棋盘), where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin  alphabet (字母表): A, . . .

Output

The  output (输出) for every  scenario (方案) begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically (辞典编纂的) first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by  concatenating (连结) the names of the visited squares. Each square name consists of a capital letter followed by a number.

If no such path exist, you should output impossible on a single line.

Sample Input

3
1 1
2 3
4 3

Sample Output

Scenario #1:
A1

Scenario #2:
impossible

Scenario #3:
A1B3C1A2B4C2A3B1C3A4B2C4

题意:

输入n,m. 即一个n*m的方格, 要求一个马(象棋里的马)能从任意地点开始,走完所有方格点。输出字典序最小的路径。

思路:

首先要明白,能从任意点遍历全图,那从第一个点也必须可以便利全图。因为要求字典序最小,所以我们就从第一个点DFS看看能否达成条件。

其次要注意,国际象棋横向是字母,竖向是数字。

第三,马走的顺序应该是x尽量小的前提下让y尽量小,才能保证字典序最小。

代码:

#include <iostream>
#include <string.h>
#include <stdio.h>
using namespace std;

int p, q;
int path_x[27], path_y[27];
bool vis[27][27], flag;

int Move[][2] = {-1,-2, 1,-2, -2,-1, 2,-1, -2,1, 2,1, -1,2, 1,2};

void DFS(int x, int y, int step)
{
	path_x[step] = x;
	path_y[step] = y;
	if(step == p*q)
	{
		flag = true;
		return;
	}
	for(int i = 0;i < 8;i++)
	{
		int xx = x + Move[i][0];
		int yy = y + Move[i][1];
		if(xx<1||yy<1||xx>p||yy>q)
			continue;
		if(!vis[xx][yy] && !flag)
		{
			vis[xx][yy] = true;
			DFS(xx,yy,step+1);
			vis[xx][yy] = false;
		}
	}
}

int main()
{
    int n;
	cin>>n;
    for(int T = 1; T <= n;T++)
	{
		memset(vis,false,sizeof(vis));
		cin>>p>>q;
		vis[1][1] = true;
		flag = false;
		DFS(1,1,1);
		cout<<"Scenario #"<<T<<':'<<endl;
		if(flag)
		{
			for(int i = 1;i <= p*q;i++)
				printf("%c%d",path_y[i]+'A'-1,path_x[i]);
		}
		else
			cout<<"impossible";
		cout<<endl<<endl;
	}
    return 0;
}


猜你喜欢

转载自blog.csdn.net/JOKER_SAMA/article/details/52201183