POJ2488 A Knight's Journey【DFS】

A Knight’s Journey
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 58714 Accepted: 19998

Description

Background
The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey
around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans?
在这里插入图片描述
Problem
Find a path such that the knight visits every square once. The knight can start and end on any square of the board.
Input

The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .

Output

The output for every scenario begins with a line containing “Scenario #i:”, where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number.
If no such path exist, you should output impossible on a single line.

Sample Input

3
1 1
2 3
4 3
Sample Output

Scenario #1:
A1

Scenario #2:
impossible

Scenario #3:
A1B3C1A2B4C2A3B1C3A4B2C4

Source
TUD Programming Contest 2005, Darmstadt, Germany

问题链接POJ2488 A Knight’s Journey
问题简述:给定国际棋盘的大小(p×q),判定马能否不重复地跳过所有格,输出其字典序顺序的第一种路径。
问题分析:经典的“骑士游历”问题,关键是跳马的顺序,保证先跳到字典顺序的点。需要注意行按数字输出列按字母输出。
程序说明:(略)
参考链接:(略)
题记:(略)

AC的C++语言程序如下:

/* POJ2488 A Knight's Journey */

#include <iostream>
#include <cstdio>
#include <cstring>

using namespace std;

const int DN = 8;
// 字典顺序方向
const int dx[] = {-1, 1, -2, 2, -2, 2, -1, 1};
const int dy[] = {-2, -2, -1, -1, 1, 1, 2, 2};

const int N = 26 + 1;
bool vis[N][N];
struct Setp {
    char x, y;
} path[N];
int p, q, success;

void dfs(int x, int y, int step)
{
    path[step].y = y + 'A' - 1;   //int 转为 char
    path[step].x = x + '0';
    if (step == p * q) success = true;
    else {
        for (int i = 0; i < DN && !success; i++) {
            int nx = x + dx[i];
            int ny = y + dy[i];
            if (0 < nx && nx <= p && 0 < ny && ny <= q &&
                    !vis[nx][ny] && !success) {
                vis[nx][ny] = true;     // 设置状态,避免回跳
                dfs(nx, ny, step + 1);
                vis[nx][ny] = false;        // 恢复状态
            }
        }
    }
}

int main()
{
    int t;
    scanf("%d", &t);
    for(int k = 1; k <= t; k++) {
        scanf("%d%d", &p, &q);

        memset(vis, false, sizeof(vis));
        vis[1][1] = true;   // 起点
        success = false;
        dfs(1, 1, 1);

        printf("Scenario #%d:\n", k);
        if(success) {
            for(int i = 1; i <= p * q; i++)
                printf("%c%c", path[i].y, path[i].x);
            printf("\n");
        } else printf("impossible\n");
        if(k != t) printf("\n");        // 空一行
    }

    return 0;
}
发布了2289 篇原创文章 · 获赞 2373 · 访问量 265万+

猜你喜欢

转载自blog.csdn.net/tigerisland45/article/details/105542288