POJ-2488 A Knight's Journey(深搜DFS)

版权声明:Copyright : 李三金,原创文章转载标明出处即可。 https://blog.csdn.net/santa9527/article/details/54424956

POJ-2488 A Knight’s Journey##

A Knight’s Journey
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 43097 Accepted: 14620

Description
Background
The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey
around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans?

Problem
Find a path such that the knight visits every square once. The knight can start and end on any square of the board.

这里写图片描述

Input
The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .

Output
The output for every scenario begins with a line containing “Scenario #i:”, where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number.
If no such path exist, you should output impossible on a single line.

Sample Input

3
1 1
2 3
4 3

Sample Output

Scenario #1:
A1

Scenario #2:
impossible

Scenario #3:
A1B3C1A2B4C2A3B1C3A4B2C4

Source
TUD Programming Contest 2005, Darmstadt, Germany

骑士如图可以走八个方向,问能否走完整个l*l的棋盘,如果能,输出走的路径,因为一定要走完,所以一定会走A1这个点,所以可以把它当成起点。

因为要存储路径并输出,所以我觉得深搜可以写。

注意题目要求路劲要按字典序,所以你走的方向也要字典序。

代码如下:

#include<stdio.h>
#include<string.h>
#include<iostream>
using namespace std;
int p,q,sx,sy,ac[30][30];//存储路径
bool vis[30][30],flag;
bool judge(int x,int y)
{
    if(x>=1&&x<=p&&y>=1&&y<=q&&!vis[x][y]&&!flag)
        return 1;
    return 0;
}
int dir[8][2]= {{-1,-2},{1,-2},{-2,-1},{2,-1},{-2,1},{2,1},{-1,2},{1,2}};//八个方向有讲究,建议自己画一张图看看
void dfs(int sx,int sy,int step)
{
    int i,nx,ny;
    ac[step][0]=sx;
    ac[step][1]=sy;
    if(step==p*q)//步数等于棋盘格子数,搜索结束
    {
        flag=1;//标记,可以走完
        return ;
    }
    for(i=0; i<8; i++)
    {
        nx=sx+dir[i][0];
        ny=sy+dir[i][1];
        if(judge(nx,ny))
        {
            vis[nx][ny]=1;
            dfs(nx,ny,step+1);
            vis[nx][ny]=0;
        }
    }
}
int main()
{
    int t,num=1;
    scanf("%d",&t);
    while(t--)
    {
        if(num!=1) printf("\n");
        scanf("%d %d",&p,&q);
        memset(vis,0,sizeof(vis));
        vis[1][1]=1;
        flag=0;
        dfs(1,1,1);
        printf("Scenario #%d:\n",num++);
        if(flag)
        {
            for(int i=1; i<=p*q; i++)
                printf("%c%d",ac[i][1]-1+'A',ac[i][0]);
        }
        else printf("impossible");
        printf("\n");
    }
}

以上。

猜你喜欢

转载自blog.csdn.net/santa9527/article/details/54424956