Lightoj1236 Pairs Forming LCM

Pairs Forming LCM

Find the result of the following code:

long long pairsFormLCM( int n ) {
    long long res = 0;
    for( int i = 1; i <= n; i++ )
        for( int j = i; j <= n; j++ )
           if( lcm(i, j) == n ) res++; // lcm means least common multiple
    return res;
}

A straight forward implementation of the code may time out. If you analyze the code, you will find that the code actually counts the number of pairs (i, j) for which lcm(i, j) = n and (i ≤ j).

Input

Input starts with an integer T (≤ 200), denoting the number of test cases.

Each case starts with a line containing an integer n (1 ≤ n ≤ 1014).

Output

For each case, print the case number and the value returned by the function 'pairsFormLCM(n)'.

Sample Input

15

2

3

4

6

8

10

12

15

18

20

21

24

25

27

29

Sample Output

Case 1: 2

Case 2: 2

Case 3: 3

Case 4: 5

Case 5: 4

Case 6: 5

Case 7: 8

Case 8: 5

Case 9: 8

Case 10: 8

Case 11: 5

Case 12: 11

Case 13: 3

Case 14: 4

Case 15: 2

思路:

对于i,j,n,我们可以分解质因子,如下:

i = p1^i1 * p2^i2... ....*pn^in

j = p1^j1 * p2^j2... ...*pn^jn

n= p1^n1 *p2^n2... ...pn^nn

由于n = lcm(i,j) = p1 ^ max(i1,j1) * p2 ^max(i2,j2) ... ... pn^max(in,jn)

所以对于每个i和j,我们都可以得到2 * n1 + 1种结果,再利用乘法原理我们就可以得到结果为

ans = (2 * n1 + 1) * (2 * n2+ 1)... ...* (2 * nn + 1)

不过题目中i >= i,即不能出现重复的,所以只要除以2就行了,n和n 是一种,所以要先加1

是故最终ans = (ans + 1) / 2

最后再说一下代码,我试过用map,不过TLE了,所以打表,但是用int标记非素数又ME了,所以用bool标记,终于解决了TLE和ME的问题,不得不感慨一下,这道题真TMD极限啊;

代码:

#include<cstdio>
#include<algorithm>
#include<map>
#include<cstring>
#define ll long long
using namespace std;
const int Maxn = 1e7 + 2;
const int maxn = 1e6 + 2;
unsigned int prime[maxn];
bool check[Maxn];
int pos = 0;
void init()
{
    memset(check,0,sizeof(check));
    memset(prime,0,sizeof(prime));

    for (int i = 2;i < Maxn;i ++)
    {
        if (!check[i])
        {
            prime[pos ++] = i;
            for (int j = i + i;j < Maxn;j += i)
                check[j] = 1;
        }
    }
}
int main()
{
    int t,casenum = 0;
    init();
    scanf("%d",&t);
    while (t --)
    {
        casenum ++;
        ll n,ans = 1;
        scanf("%lld",&n);
        for (int i = 0;i < pos && prime[i] * prime[i] <= n;i ++)
        {
            int num = 0;
            while (n % prime[i] == 0)
            {
                num ++;
                n /= prime[i];
            }
            if (num) ans *= 2 * num + 1;
        }
        if (n != 1) ans *= 3;
        printf("Case %d: %lld\n",casenum,(ans + 1) / 2);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/cloudy_happy/article/details/81212118
lcm
今日推荐