Pairs Forming LCM LightOJ - 1236

题目链接:https://cn.vjudge.net/problem/LightOJ-1236

Find the result of the following code:

long long pairsFormLCM( int n ) {
    long long res = 0;
    for( int i = 1; i <= n; i++ )
        for( int j = i; j <= n; j++ )
           if( lcm(i, j) == n ) res++; // lcm means least common multiple
    return res;
}

A straight forward implementation of the code may time out. If you analyze the code, you will find that the code actually counts the number of pairs (i, j) for which lcm(i, j) = n and (i ≤ j).

Input

Input starts with an integer T (≤ 200), denoting the number of test cases.

Each case starts with a line containing an integer n (1 ≤ n ≤ 1014).

Output

For each case, print the case number and the value returned by the function 'pairsFormLCM(n)'.

Sample Input

15

2

3

4

6

8

10

12

15

18

20

21

24

25

27

29

Sample Output

Case 1: 2

Case 2: 2

Case 3: 3

Case 4: 5

Case 5: 4

Case 6: 5

Case 7: 8

Case 8: 5

Case 9: 8

Case 10: 8

Case 11: 5

Case 12: 11

Case 13: 3

Case 14: 4

Case 15: 2

题目大意:给你一个数n  求满足lcm(a, b) == n, a <= b 的 (a,b) 的个数。

思路:唯一分解定理。求出每个素因子的个数xi,然后t=(2*x1+1)*......(n*xi+1),然后i==j只有一种所以i<j的有(t-1)/2所以加上i==j的(t+1)/2就是答案。

代码:

#include <bits/stdc++.h>
using namespace std;
typedef long long ll;
const int maxn=1e7+10;
ll prime[maxn/10];
bool vis[maxn];
int cnt=0;
void oula()
{
    memset(vis,false,sizeof(vis));
    memset(prime,0,sizeof(prime));
    for(int i=2;i<=maxn;i++)
    {
        if(!vis[i])
        {
            prime[cnt++]=i;
        }
        for(int j=0;j<cnt&&i*prime[j]<=maxn;j++)
        {
            vis[i*prime[j]]=true;
            if(i%prime[j]==0)
            break;
        }
    }
}
int main()
{
    oula();
    int t;
    scanf("%d",&t);
    for(int kcase=1;kcase<=t;kcase++)
    {
        ll n;
        scanf("%lld",&n);
        ll ans=1;
        for(int i=0;i<cnt&&prime[i]*prime[i]<=n;i++)
        {
            ll num=0;
            while(n%prime[i]==0)
            {
                num++;
                n/=prime[i];
            }
            ans*=(2*num+1);
        }
        if(n>1)
        ans*=3;
        ans=(ans+1)/2;
        cout<<"Case "<<kcase<<": "<<ans<<endl;
    }
}

猜你喜欢

转载自blog.csdn.net/HTallperson/article/details/84309267
今日推荐