LightOJ 1236 Pairs Forming LCM (算术基本定理 + 最小公倍数)

LightOJ 1236 Pairs Forming LCM (算术基本定理 + 最小公倍数)

Find the result of the following code:

long long pairsFormLCM( int n ) {
   
 long long res = 0;
   
 for( int i = 1; i <= n; i++ )
       
 for( int j = i; j <= n; j++ )
           
if( lcm(i, j) == n ) res++; // lcm means least common multiple
   
 return res;
}

A straight forward implementation of the code may time out. If you analyze the code, you will find that the code actually counts the number of pairs (i, j) for which lcm(i, j) = n and (i ≤ j).

Input

Input starts with an integer T (≤ 200), denoting the number of test cases.

Each case starts with a line containing an integer n (1 ≤ n ≤ 1014).

Output

For each case, print the case number and the value returned by the function 'pairsFormLCM(n)'.

Sample Input

15

2

3

4

6

8

10

12

15

18

20

21

24

25

27

29

Sample Output

Case 1: 2

Case 2: 2

Case 3: 3

Case 4: 5

Case 5: 4

Case 6: 5

Case 7: 8

Case 8: 5

Case 9: 8

Case 10: 8

Case 11: 5

Case 12: 11

Case 13: 3

Case 14: 4

Case 15: 2


n分解为素数指数积的形式  n = π(pi^ai)   

1. 在a中的指数 ai == ei   那么 pi 在 b 中的指数可取 [0, ei] 中的所有数  有 ai + 1 种情况

2. 在a中的指数 ai < ei  即 ai 在 [0, ei) 中   那么 pi 在 b 中的指数只能取 ai  有 ei 种情况

每个素因子都有 2*ei + 1种情况  也就是满足条件的 (a, b) 有 π(2*ei + 1)个  考虑大小时 除了 (n, n) 所有的情况都出现了两次  那么满足a<=b的有 (π(2*ai + 1)) / 2 + 1  种情况


#include <cstdio>
#include <cstring>
using namespace std;         //这个sqrt是针对算术基本定理来的
#define MAXN 10000005     //sqrt(10^14)
int prime[MAXN/10], m;   //存素数不能开太大 /10
bool vis[MAXN];    //int 改成 bool  就减少内存了,吐血
void GetPrime()
{
    long long i,j;
    memset(vis,0,sizeof(vis));
    memset(prime,0,sizeof(prime));
    for(i=2;i<=MAXN;i++)                 //这里的MAXN是所有数的个数
    {
        if(vis[i]==0)
        {
            prime[m++]=i;
            for(j=2*i;j<=MAXN;j+=i)
            {
                vis[j]=1;
            }
        }
    }
}
long long factor_cnt(long long n)
{
    long long
    sum=1;
    if(n==0)
    return 0;
    long long a=0;
    long long i=0;
    while((long long )prime[i]*prime[i]<=n&&i<m)
    {
        a=0;
        if(n%prime[i]==0)
        {
            while(n%prime[i]==0)
            {
                n/=prime[i];
                a++;
            }
        }
        if(a!=0)      //很重要
        sum*=1+2*a;
        i++;         //i也不能无限增长
    }
    if(n>1)
    sum*=1+2;
    return sum/2+1;
}
int main()
{
    GetPrime();
    int  t;
    int cas=1;
    scanf("%d",&t);
    while(t--)
    {
        long long n;
        scanf("%lld",&n);
        printf("Case %d: %lld\n",cas++,factor_cnt(n));
    }
    return 0;
}




猜你喜欢

转载自blog.csdn.net/xigongdali/article/details/80530477