POJ2488(深搜)

题目:

Background
The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey
around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans?

Problem
Find a path such that the knight visits every square once. The knight can start and end on any square of the board.

Input

The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .

Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number.
If no such path exist, you should output impossible on a single line.

Sample Input

3
1 1
2 3
4 3

Sample Output

Scenario #1:
A1

Scenario #2:
impossible

Scenario #3:
A1B3C1A2B4C2A3B1C3A4B2C4
/*题意:判断一个骑士是否能够不重复走完棋盘上的点,按照国际象棋中马的规则走,输出
字典序最小的序列*/
#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;
int vis[100][100];
int map[100][2];
int dir[8][2]={{-2,-1},{-2,1},{-1,-2},{-1,2},{1,-2},{1,2},{2,-1},{2,1}};
int p,q,flag;
void DFS(int x,int y,int num)
{
	if(num==p*q)
	{
		flag=1;
		for(int i=0;i<num;i++)
		{
			printf("%c%d",map[i][0]+'A',map[i][1]+1);
		}
		printf("\n");
	}
	else
    {
	for(int i=0;i<8;i++)
	{
		int m=x+dir[i][0];
		int n=y+dir[i][1];
		if(m>=0&&m<q&&n>=0&&n<p&&!flag&&!vis[m][n])
		{
			vis[m][n]=1;
			map[num][0]=m;
			map[num][1]=n;
			DFS(m,n,num+1);
			vis[m][n]=0;
		}
	}
    }
}
int main()
{
	int t,ex=1;
	cin>>t;
	while(t--)
	{
		cin>>p>>q;
		flag=0;
		memset(vis,0,sizeof(vis));
		memset(map,0,sizeof(map));
		vis[0][0]=1;
		printf("Scenario #%d:\n",ex++);
		DFS(0,0,1);
		if(!flag) printf("impossible\n");
		printf("\n");
	}
	return 0;
 }

猜你喜欢

转载自blog.csdn.net/rain699/article/details/82181486