[欧拉回路] hdu 3018 Ant Trip

题目链接:

http://acm.hdu.edu.cn/showproblem.php?pid=3018

Ant Trip

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1658    Accepted Submission(s): 641


Problem Description
Ant Country consist of N towns.There are M roads connecting the towns.

Ant Tony,together with his friends,wants to go through every part of the country. 

They intend to visit every road , and every road must be visited for exact one time.However,it may be a mission impossible for only one group of people.So they are trying to divide all the people into several groups,and each may start at different town.Now tony wants to know what is the least groups of ants that needs to form to achieve their goal.
 

Input
Input contains multiple cases.Test cases are separated by several blank lines. Each test case starts with two integer N(1<=N<=100000),M(0<=M<=200000),indicating that there are N towns and M roads in Ant Country.Followed by M lines,each line contains two integers a,b,(1<=a,b<=N) indicating that there is a road connecting town a and town b.No two roads will be the same,and there is no road connecting the same town.
 

Output
For each test case ,output the least groups that needs to form to achieve their goal.
 

Sample Input
 
  
3 3 1 2 2 3 1 3 4 2 1 2 3 4
 

Sample Output
 
  
1 2
Hint
New ~~~ Notice: if there are no road connecting one town ,tony may forget about the town. In sample 1,tony and his friends just form one group,they can start at either town 1,2,or 3. In sample 2,tony and his friends must form two group.
 

Source
 

Recommend
gaojie   |   We have carefully selected several similar problems for you:   3013  3015  3016  3011  3010 
 

Statistic |  Submit |  Discuss |  Note

题目意思:

给一幅无向图,求要用多少次一笔画,把所有边走完,边只能走一次。孤立点不算。

解题思路:
dfs把每个连通块找到,然后统计奇数度数节点个数。

注意孤立节点不算。

代码:

//#include<CSpreadSheet.h>

#include<iostream>
#include<cmath>
#include<cstdio>
#include<sstream>
#include<cstdlib>
#include<string>
#include<string.h>
#include<cstring>
#include<algorithm>
#include<vector>
#include<map>
#include<set>
#include<stack>
#include<list>
#include<queue>
#include<ctime>
#include<bitset>
#include<cmath>
#define eps 1e-6
#define INF 0x3f3f3f3f
#define PI acos(-1.0)
#define ll __int64
#define LL long long
#define lson l,m,(rt<<1)
#define rson m+1,r,(rt<<1)|1
#define M 1000000007
//#pragma comment(linker, "/STACK:1024000000,1024000000")
using namespace std;

#define Maxn 110000
int de[Maxn],n,m;
vector<vector<int> >myv;
int in[Maxn],cnt;
bool vis[Maxn];

void dfs(int cur)
{
    in[++cnt]=cur;
    vis[cur]=true;
    for(int i=0;i<myv[cur].size();i++)
    {
        int ne=myv[cur][i];
        if(vis[ne])
            continue;
        dfs(ne);
    }
}
int main()
{
    //freopen("in.txt","r",stdin);
   //freopen("out.txt","w",stdout);
   while(~scanf("%d%d",&n,&m))
   {
       myv.clear();
       myv.resize(n+10);
       memset(de,0,sizeof(de));

       for(int i=1;i<=m;i++)
       {
           int a,b;
           scanf("%d%d",&a,&b);
           myv[a].push_back(b);
           myv[b].push_back(a);
           de[a]++;
           de[b]++;
       }
       memset(vis,false,sizeof(vis));

       int ans=0;

       for(int i=1;i<=n;i++)
       {
           if(!vis[i])
           {
               cnt=0;
               dfs(i);
               int temp=0;
               if(cnt==1)  //孤立节点不算
                    continue;
               for(int j=1;j<=cnt;j++)
               {
                   if(de[in[j]]&1)
                        temp++;
                    //printf("i:%d j")
               }
               if(!temp)
                    ans++;
               else
                    ans+=temp/2;
           }
       }
       printf("%d\n",ans);

   }
    return 0;
}



猜你喜欢

转载自blog.csdn.net/cc_again/article/details/39932607
今日推荐