PAT (Advanced Level) Practice A1070 Mooncake (25 分)(C++)(甲级)(排序)

版权声明:假装有个原创声明……虽然少许博文不属于完全原创,但也是自己辛辛苦苦总结的,转载请注明出处,感谢! https://blog.csdn.net/m0_37454852/article/details/86494967

1070 Mooncake (25 分)
Mooncake is a Chinese bakery product traditionally eaten during the Mid-Autumn Festival. Many types of fillings and crusts can be found in traditional mooncakes according to the region’s culture. Now given the inventory amounts and the prices of all kinds of the mooncakes, together with the maximum total demand of the market, you are supposed to tell the maximum profit that can be made.

Note: partial inventory storage can be taken. The sample shows the following situation: given three kinds of mooncakes with inventory amounts being 180, 150, and 100 thousand tons, and the prices being 7.5, 7.2, and 4.5 billion yuans. If the market demand can be at most 200 thousand tons, the best we can do is to sell 150 thousand tons of the second kind of mooncake, and 50 thousand tons of the third kind. Hence the total profit is 7.2 + 4.5/2 = 9.45 (billion yuans).

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers N (≤1000), the number of different kinds of mooncakes, and D (≤500 thousand tons), the maximum total demand of the market. Then the second line gives the positive inventory amounts (in thousand tons), and the third line gives the positive prices (in billion yuans) of N kinds of mooncakes. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the maximum profit (in billion yuans) in one line, accurate up to 2 decimal places.

Sample Input:

3 200
180 150 100
7.5 7.2 4.5
Sample Output:

9.45

//B1020英文版
//https://blog.csdn.net/m0_37454852/article/details/86494906

using namespace std;
#include<algorithm>
#include<iostream>
#include<cstdio>
#include<cstring>

typedef struct MoonCake//因精度问题,都设置成double
{
    double stock;//库存量
    double price;//单价
    double Total;//价格总额
}MoonCake;
MoonCake M[1010] {0};

bool cmp(MoonCake a, MoonCake b)
{
    return a.price > b.price;
}

int main()
{
    int N, D;
    scanf("%d %d", &N, &D);
    for(int i=0; i<N; i++) scanf("%lf", &M[i].stock);
    for(int i=0; i<N; i++) scanf("%lf", &M[i].Total);
    for(int i=0; i<N; i++)
    {
        if(M[i].stock)
        {
            M[i].price = M[i].Total/M[i].stock;//计算单价
        }
    }
    sort(M, M+N, cmp);//按价格降序排列
    double earn = 0;
    for(int i=0; i<N; i++)
    {
        if(M[i].stock < D) earn += M[i].Total;//该月饼的库存量小于剩余需求
        else
        {
            earn += D*M[i].price;//否则只计算需求部分
            break;
        }
        D = D - M[i].stock;//需求量减少
    }
    printf("%.2lf", earn);
    return 0;
}

猜你喜欢

转载自blog.csdn.net/m0_37454852/article/details/86494967
今日推荐