Cheerleaders UVA - 11806 计数问题

In most professional sporting events, cheerleaders play a major role in entertaining the spectators. Their
roles are substantial during breaks and prior to start of play. The world cup soccer is no exception.
Usually the cheerleaders form a group and perform at the centre of the eld. In addition to this group,
some of them are placed outside the side line so they are closer to the spectators. The organizers would
like to ensure that at least one cheerleader is located on each of the four sides. For this problem, we
will model the playing ground as an
M

N
rectangular grid. The constraints for placing cheerleaders
are described below:

There should be at least one cheerleader on each of the four sides. Note that, placing a cheerleader
on a corner cell would cover two sides simultaneously.

There can be at most one cheerleader in a cell.

All the cheerleaders available must be assigned to a cell. That is, none of them can be left out.
The organizers would like to know, how many ways they can place the cheerleaders while maintaining
the above constraints. Two placements are different, if there is at least one cell which contains a
cheerleader in one of the placement but not in the other.
Input
The rst line of input contains a positive integer
T

50, which denotes the number of test cases.
T
lines then follow each describing one test case. Each case consists of three nonnegative integers, 2

M
,
N

20 and
K

500. Here
M
is the number of rows and
N
is the number of columns in the grid.
K
denotes the number of cheerleaders that must be assigned to the cells in the grid.
Output
For each case of input, there will be one line of output. It will rst contain the case number followed by
the number of ways to place the cheerleaders as described earlier. Look at the sample output for exact
formatting. Note that, the numbers can be arbitrarily large. Therefore you must output the answers
modulo
1000007.
Sample Input
2
2 2 1
2 3 2
Sample Output
Case 1: 0
Case 2: 2
 
简单的计数问题;
题目所说:第一行,最后一行,第一列,最后一列都得有石子;
设集合A:不在第一行,
集合B:不在最后一行;
集合C:不在第一列;
集合D:不在最后一列;
总集合为S的话,那么我们要求的就是在S中而且不在集合ABCD中的个数;
那我们用二进制来表示,总的数量为2^4=16种情况;
容斥一下就Ok了;
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstdlib>
#include<cstring>
#include<string>
#include<cmath>
#include<map>
#include<set>
#include<vector>
#include<queue>
#include<bitset>
#include<ctime>
#include<deque>
#include<stack>
#include<functional>
#include<sstream>
//#include<cctype>
//#pragma GCC optimize(2)
using namespace std;
#define maxn 2000005
#define inf 0x7fffffff
//#define INF 1e18
#define rdint(x) scanf("%d",&x)
#define rdllt(x) scanf("%lld",&x)
#define rdult(x) scanf("%lu",&x)
#define rdlf(x) scanf("%lf",&x)
#define rdstr(x) scanf("%s",x)
typedef long long  ll;
typedef unsigned long long ull;
typedef unsigned int U;
#define ms(x) memset((x),0,sizeof(x))
const long long int mod = 1e6 + 7;
#define Mod 1000000000
#define sq(x) (x)*(x)
#define eps 1e-4
typedef pair<int, int> pii;
#define pi acos(-1.0)
//const int N = 1005;
#define REP(i,n) for(int i=0;i<(n);i++)
typedef pair<int, int> pii;
inline ll rd() {
	ll x = 0;
	char c = getchar();
	bool f = false;
	while (!isdigit(c)) {
		if (c == '-') f = true;
		c = getchar();
	}
	while (isdigit(c)) {
		x = (x << 1) + (x << 3) + (c ^ 48);
		c = getchar();
	}
	return f ? -x : x;
}

ll gcd(ll a, ll b) {
	return b == 0 ? a : gcd(b, a%b);
}
int sqr(int x) { return x * x; }


/*ll ans;
ll exgcd(ll a, ll b, ll &x, ll &y) {
	if (!b) {
		x = 1; y = 0; return a;
	}
	ans = exgcd(b, a%b, x, y);
	ll t = x; x = y; y = t - a / b * y;
	return ans;
}
*/

int c[503][503];
int n, m, k;
void init() {
	c[0][0] = 1;
	for (int i = 0; i <= 503; i++) {
		c[i][0] = c[i][i] = 1;
		for (int j = 1; j < i; j++)c[i][j] = (c[i - 1][j] + c[i - 1][j - 1]) % mod;
	}
}

int main() {
//	ios_base::sync_with_stdio(0); cin.tie(0); cout.tie(0);
	int T; cin >> T;
	init(); int tot = 0;
	while (T--) {
		tot++;
		cin >> n >> m >> k;
		cout << "Case " << tot << ": ";
		int sum = 0;
		for (int i = 0; i < 16; i++) {
			int bk = 0;
			int r = n, C = m;
			if (i & 1) { bk++; r--; }
			if (i & 2) { bk++; r--; }
			if (i & 4) { bk++; C--; }
			if (i & 8) { bk++; C--; }
			if (bk % 2) {
				sum = (sum + mod - c[C*r][k]) % mod;
			}
			else sum = (sum + c[C*r][k]) % mod;
		}
		cout << sum << endl;
	}
	return 0;
}

猜你喜欢

转载自www.cnblogs.com/zxyqzy/p/10322942.html