[POJ2828]Buy Tickets

Railway tickets were difficult to buy around the Lunar New Year in China, so we must get up early and join a long queue…

The Lunar New Year was approaching, but unluckily the Little Cat still had schedules going here and there. Now, he had to travel by train to Mianyang, Sichuan Province for the winter camp selection of the national team of Olympiad in Informatics.

It was one o’clock a.m. and dark outside. Chill wind from the northwest did not scare off the people in the queue. The cold night gave the Little Cat a shiver. Why not find a problem to think about? That was none the less better than freezing to death!

People kept jumping the queue. Since it was too dark around, such moves would not be discovered even by the people adjacent to the queue-jumpers. “If every person in the queue is assigned an integral value and all the information about those who have jumped the queue and where they stand after queue-jumping is given, can I find out the final order of people in the queue?” Thought the Little Cat.

Input
There will be several test cases in the input. Each test case consists of N + 1 lines where N (1 ≤ N ≤ 200,000) is given in the first line of the test case. The next N lines contain the pairs of values Posi and Vali in the increasing order of i (1 ≤ i ≤ N). For each i, the ranges and meanings of Posi and Vali are as follows:

Posi ∈ [0, i − 1] — The i-th person came to the queue and stood right behind the Posi-th person in the queue. The booking office was considered the 0th person and the person at the front of the queue was considered the first person in the queue.
Vali ∈ [0, 32767] — The i-th person was assigned the value Vali.
There no blank lines between test cases. Proceed to the end of input.

Output
For each test cases, output a single line of space-separated integers which are the values of people in the order they stand in the queue.

Sample Input
4
0 77
1 51
1 33
2 69
4
0 20523
1 19243
1 3890
0 31492
Sample Output
77 33 69 51
31492 20523 3890 19243
Hint
The figure below shows how the Little Cat found out the final order of people in the queue described in the first test case of the sample input.

嗯…
一道非常久远的题了
题意基本上全是废话
一句话翻译一下就是
现在有一个空的队列,有一堆人要插进来,第 i i 个人要插在第 p o s i pos_i 个人后面,每个人有一个数 v a l i val_i 现在让你输出最后所有人插进去之后的队列的 v a l val

刚开始以为是链表,结果发现插入的位置有点不太好弄
那么这时候就需要我们开动脑筋把问题转化一下
我们正着插的时候不知道我们要差到哪里,但是,如果我们把插队的顺序反过来,开始踢人,那么我们每次踢人的位置就确定了

知道了这个有什么用呢?

就可以用线段树维护了
用一棵线段树维护空位的个数,每次踢走一个人在那个位置上空为数就要-1
然后就没了
(看代码就懂了)

# include <cstdio>
# include <algorithm>
# include <cstring>
# include <cmath>
# include <climits>
# include <iostream>
# include <string>
# include <queue>
# include <stack>
# include <vector>
# include <set>
# include <map>
# include <cstdlib>
# include <ctime>
using namespace std;

# define Rep(i,a,b) for(int i=a;i<=b;i++)
# define _Rep(i,a,b) for(int i=a;i>=b;i--)
# define RepG(i,u) for(int i=head[u];~i;i=e[i].next)

typedef long long ll;
const int N=2e5+5;
const int inf=0x7fffffff;
const double eps=1e-7;
template <typename T> void read(T &x){
	x=0;int f=1;
	char c=getchar();
	for(;!isdigit(c);c=getchar())if(c=='-')f=-1;
	for(;isdigit(c);c=getchar())x=(x<<1)+(x<<3)+c-'0';
	x*=f;
}

int n,ans[N<<2];
int pos[N],val[N];

struct segment_tree{
	int l,r,val;	
}seg[N<<2];

# define lc (u<<1)
# define rc (u<<1|1)

void build(int u,int l,int r){
	seg[u].l=l,seg[u].r=r;	
	seg[u].val=r-l+1;
	if(l==r)return;
	int mid=l+r>>1;
	build(lc,l,mid);
	build(rc,mid+1,r);
}

void insert(int u,int pos,int k){
	if(seg[u].l==seg[u].r){seg[u].val--,ans[u]=k;return;}
	if(pos<=seg[lc].val)insert(lc,pos,k);
	else insert(rc,pos-seg[lc].val,k);
	seg[u].val=seg[lc].val+seg[rc].val;
}

void dfs(int u){
	if(seg[u].l==seg[u].r){printf("%d ",ans[u]);return;}
	dfs(lc);
	dfs(rc);	
}

int main()
{
	while(~scanf("%d",&n)){
		build(1,1,n);
		Rep(i,1,n)read(pos[i]),read(val[i]);
		_Rep(i,n,1)insert(1,pos[i]+1,val[i]);
		dfs(1);
		printf("\n"); 
	}
	return 0;
}
发布了18 篇原创文章 · 获赞 3 · 访问量 1255

猜你喜欢

转载自blog.csdn.net/devout_/article/details/104077024