Buy Tickets POJ - 2828(线段树离线)

Railway tickets were difficult to buy around the Lunar New Year in China, so we must get up early and join a long queue…

The Lunar New Year was approaching, but unluckily the Little Cat still had schedules going here and there. Now, he had to travel by train to Mianyang, Sichuan Province for the winter camp selection of the national team of Olympiad in Informatics.

It was one o’clock a.m. and dark outside. Chill wind from the northwest did not scare off the people in the queue. The cold night gave the Little Cat a shiver. Why not find a problem to think about? That was none the less better than freezing to death!

People kept jumping the queue. Since it was too dark around, such moves would not be discovered even by the people adjacent to the queue-jumpers. “If every person in the queue is assigned an integral value and all the information about those who have jumped the queue and where they stand after queue-jumping is given, can I find out the final order of people in the queue?” Thought the Little Cat.

Input
There will be several test cases in the input. Each test case consists of N + 1 lines where N (1 ≤ N ≤ 200,000) is given in the first line of the test case. The next N lines contain the pairs of values Posi and Vali in the increasing order of i (1 ≤ i ≤ N). For each i, the ranges and meanings of Posi and Vali are as follows:

Posi ∈ [0, i − 1] — The i-th person came to the queue and stood right behind the Posi-th person in the queue. The booking office was considered the 0th person and the person at the front of the queue was considered the first person in the queue.
Vali ∈ [0, 32767] — The i-th person was assigned the value Vali.
There no blank lines between test cases. Proceed to the end of input.

Output
For each test cases, output a single line of space-separated integers which are the values of people in the order they stand in the queue.

Sample Input
4
0 77
1 51
1 33
2 69
4
0 20523
1 19243
1 3890
0 31492
Sample Output
77 33 69 51
31492 20523 3890 19243
Hint
The figure below shows how the Little Cat found out the final order of people in the queue described in the first test case of the sample input.

题意:
将a插入到b位置。如果b位置有人,就往后推一格,以此类推。
思路:
正向考虑,要插队就得成块移动,只能用链表维护了。
逆向考虑,最后一个进入第b个位置的人,肯定就是这个位置的主人。
前一个占了这个位置的人,要往后推一格。
逆向考虑就成了不能插队的情况,只能往后跑。
那么就成了找第k个没有人的位置。
维护线段树sum值即可。

#include <cstdio>
#include <cstring>
#include <algorithm>

using namespace std;

const int maxn = 2e5 + 7;
int vis[maxn];

struct Node
{
    int l,r;
    int cover;
    int sum;
}t[maxn << 2];

struct NODE
{
    int pos,val;
}p[maxn];

void pushup(int i)
{
    t[i].sum = t[i * 2].sum + t[i * 2 + 1].sum;
}

void build(int i,int l,int r)
{
    t[i].l = l;t[i].r = r;
    if(l == r)
    {
        t[i].sum = 1;
        t[i].cover = 0;
        return;
    }
    int m = (t[i].l + t[i].r) >> 1;
    build(i * 2,l,m);
    build(i * 2 + 1,m + 1,r);
    pushup(i);
}

void update(int i,int v,int id)
{
    if(t[i].l == t[i].r)
    {
        t[i].sum = 0;
        t[i].cover = id;
        return;
    }
    if(t[i * 2].sum >= v)update(i * 2,v,id);
    else update(i * 2 + 1,v - t[i * 2].sum,id);
    pushup(i);
}

void All(int i)
{
    if(t[i].l == t[i].r)
    {
        printf("%d ",t[i].cover);
        return;
    }
    All(i * 2);
    All(i * 2 + 1);
}

int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        build(1,1,n);
        for(int i = 1;i <= n;i++)
        {
            scanf("%d%d",&p[i].pos,&p[i].val);
            p[i].pos++;
        }
        
        for(int i = n;i >= 1;i--)
        {
            int pos = p[i].pos,val = p[i].val;
//            printf("%d ",pos);
            update(1,pos,val);
        }
        All(1);
        printf("\n");
    }
    return 0;
}

发布了628 篇原创文章 · 获赞 17 · 访问量 2万+

猜你喜欢

转载自blog.csdn.net/tomjobs/article/details/104077734