Buy Tickets( POJ 2828 )

Railway tickets were difficult to buy around the Lunar New Year in China, so we must get up early and join a long queue…

The Lunar New Year was approaching, but unluckily the Little Cat still had schedules going here and there. Now, he had to travel by train to Mianyang, Sichuan Province for the winter camp selection of the national team of Olympiad in Informatics.

It was one o’clock a.m. and dark outside. Chill wind from the northwest did not scare off the people in the queue. The cold night gave the Little Cat a shiver. Why not find a problem to think about? That was none the less better than freezing to death!

People kept jumping the queue. Since it was too dark around, such moves would not be discovered even by the people adjacent to the queue-jumpers. “If every person in the queue is assigned an integral value and all the information about those who have jumped the queue and where they stand after queue-jumping is given, can I find out the final order of people in the queue?” Thought the Little Cat.

Input

There will be several test cases in the input. Each test case consists of N + 1 lines where N (1 ≤ N ≤ 200,000) is given in the first line of the test case. The next N lines contain the pairs of values Posi and Vali in the increasing order of i(1 ≤ i ≤ N). For each i, the ranges and meanings of Posi and Vali are as follows:

  • Posi ∈ [0, i − 1] — The i-th person came to the queue and stood right behind the Posi-th person in the queue. The booking office was considered the 0th person and the person at the front of the queue was considered the first person in the queue.
  • Vali ∈ [0, 32767] — The i-th person was assigned the value Vali.

There no blank lines between test cases. Proceed to the end of input.

Output

For each test cases, output a single line of space-separated integers which are the values of people in the order they stand in the queue.

Sample Input

4
0 77
1 51
1 33
2 69
4
0 20523
1 19243
1 3890
0 31492

Sample Output

77 33 69 51
31492 20523 3890 19243

Hint

The figure below shows how the Little Cat found out the final order of people in the queue described in the first test case of the sample input.

 题意很简单,就是典型的插队,但是如何插很关键。如果按输入顺序来插的话,比如A,B分别插入位置3之后,那样移动的数很大,效率很低。如果我们从后往前插,最后插的位置其实已经固定了,前面插的如果前面有空位就往前面插,否则往后面插,再借助于线段树的话,效率比较高。

#include<bits/stdc++.h>
using namespace std;
const int maxn=2e5+5;
#define lson i*2,l,mid
#define rson i*2+1,mid+1,r
struct node
{
    int p,v;
}node[maxn];
int val[maxn*4];
int sum[maxn*4];
int cnt,n;
void pushup(int i)
{
    sum[i]=sum[i*2]+sum[i*2+1];
}
void build(int i,int l,int r)
{
    if(l==r)
    {
        sum[i]=1;
        return;
    }
    int mid=(l+r)/2;
    build(lson);
    build(rson);
    pushup(i);
}
void update(int p,int v,int i,int l,int r)
{
    if(l==r)
    {
        if(sum[i]) sum[i]=0,val[i]=v;
        return;
    }
    int mid=(l+r)/2;
    if(p<=sum[i*2]) update(p,v,lson);
    else update(p-sum[i*2],v,rson);
    pushup(i);
}
void print(int i,int l,int r)
{
    if(l==r)
    {
        cnt++;
        printf("%d",val[i]);
        if(cnt<n) printf(" ");
        else printf("\n");
        return;
    }
    int mid=(l+r)/2;
    print(lson);
    print(rson);
}
int main()
{
    while(scanf("%d",&n)==1&&n)
    {
        cnt=0;
        build(1,1,n);
        for(int i=1;i<=n;i++)
        {
            scanf("%d%d",&node[i].p,&node[i].v);
            node[i].p++;
        }
        for(int i=n;i>=1;i--)
            update(node[i].p,node[i].v,1,1,n);
        print(1,1,n);
    }
}

猜你喜欢

转载自blog.csdn.net/qq_41061455/article/details/81490459