POJ-2828-Buy Tickets (线段树单点更新)

Railway tickets were difficult to buy around the Lunar New Year in China, so we must get up early and join a long queue…

The Lunar New Year was approaching, but unluckily the Little Cat still had schedules going here and there. Now, he had to travel by train to Mianyang, Sichuan Province for the winter camp selection of the national team of Olympiad in Informatics.

It was one o’clock a.m. and dark outside. Chill wind from the northwest did not scare off the people in the queue. The cold night gave the Little Cat a shiver. Why not find a problem to think about? That was none the less better than freezing to death!

People kept jumping the queue. Since it was too dark around, such moves would not be discovered even by the people adjacent to the queue-jumpers. “If every person in the queue is assigned an integral value and all the information about those who have jumped the queue and where they stand after queue-jumping is given, can I find out the final order of people in the queue?” Thought the Little Cat.

Input

There will be several test cases in the input. Each test case consists of N + 1 lines where N (1 ≤ N ≤ 200,000) is given in the first line of the test case. The next N lines contain the pairs of values Posi and Vali in the increasing order of i (1 ≤ i ≤ N). For each i, the ranges and meanings of Posi and Vali are as follows:

  • Posi ∈ [0, i − 1] — The i-th person came to the queue and stood right behind the Posi-th person in the queue. The booking office was considered the 0th person and the person at the front of the queue was considered the first person in the queue.
  • Vali ∈ [0, 32767] — The i-th person was assigned the value Vali.

There no blank lines between test cases. Proceed to the end of input.

Output

For each test cases, output a single line of space-separated integers which are the values of people in the order they stand in the queue.

Sample Input
4
0 77
1 51
1 33
2 69
4
0 20523
1 19243
1 3890
0 31492
Sample Output
77 33 69 51
31492 20523 3890 19243
Hint

The figure below shows how the Little Cat found out the final order of people in the queue described in the first test case of the sample input.


题意:给你N个人的队列,每个人都有想站的位置,要你从前往后的给他们排序,输出最后的结果。注意,后面的人会覆盖前面的。就是是原本在该位置上的人往后移动一个位置。

思路:我们可以发现最后一个人的位置是确定的,所以逆向思维考虑。把总人数当做区间建立一个线段树,然后模拟过程即可。

#include <cstdio>
#include <iostream>
#include <algorithm>
using namespace std;
#define lc rt<<1
#define rc rt<<1|1
#define lson l, m, lc
#define rson m+1, r, rc
#define abbreviations int l,int r,int rt
#define mid (l+r)>>1
const int maxn = 200005;
int n, sum[maxn*4], pos[maxn], id[maxn], ans[maxn];
inline void pushup(int rt) { sum[rt] = sum[lc] + sum[rc]; }

void build(abbreviations)
{
    if(l == r) { sum[rt] = 1; return; }
    int m = mid;
    build(lson);
    build(rson);
    pushup(rt);
}
void update(abbreviations, int pos, int id)
{
    if(l == r) { ans[l] = id; sum[rt] = 0; return; }
    int m = mid;
    if(sum[lc] >= pos) update(lson, pos, id);
    else update(rson, pos - sum[lc], id);
    pushup(rt);
}
int main() {
    while(~scanf("%d", &n))
    {
        build(1, n, 1);
        for(int i = 0; i < n; i++) { scanf("%d%d", &pos[i],&id[i]); }
        for(int i = n-1; i >= 0; i--) update(1, n, 1, pos[i]+1, id[i]);
        for(int i = 1; i <= n; i++) printf("%d ", ans[i]);
        puts("");
    }
    return 0;
}


猜你喜欢

转载自blog.csdn.net/sugarbliss/article/details/80488890