poj2828Buy Tickets 线段树点修改(更新查询合并)

Buy Tickets

Time Limit: 4000MS   Memory Limit: 65536K
Total Submissions: 23833   Accepted: 11552

Description

Railway tickets were difficult to buy around the Lunar New Year in China, so we must get up early and join a long queue…

The Lunar New Year was approaching, but unluckily the Little Cat still had schedules going here and there. Now, he had to travel by train to Mianyang, Sichuan Province for the winter camp selection of the national team of Olympiad in Informatics.

It was one o’clock a.m. and dark outside. Chill wind from the northwest did not scare off the people in the queue. The cold night gave the Little Cat a shiver. Why not find a problem to think about? That was none the less better than freezing to death!

People kept jumping the queue. Since it was too dark around, such moves would not be discovered even by the people adjacent to the queue-jumpers. “If every person in the queue is assigned an integral value and all the information about those who have jumped the queue and where they stand after queue-jumping is given, can I find out the final order of people in the queue?” Thought the Little Cat.

Input

There will be several test cases in the input. Each test case consists of N + 1 lines where N (1 ≤ N ≤ 200,000) is given in the first line of the test case. The next N lines contain the pairs of values Posiand Vali in the increasing order of i (1 ≤ i ≤ N). For each i, the ranges and meanings of Posi and Vali are as follows:

  • Posi ∈ [0, i − 1] — The i-th person came to the queue and stood right behind the Posi-th person in the queue. The booking office was considered the 0th person and the person at the front of the queue was considered the first person in the queue.
  • Vali ∈ [0, 32767] — The i-th person was assigned the value Vali.

There no blank lines between test cases. Proceed to the end of input.

Output

For each test cases, output a single line of space-separated integers which are the values of people in the order they stand in the queue.

Sample Input

4
0 77
1 51
1 33
2 69
4
0 20523
1 19243
1 3890
0 31492

Sample Output

77 33 69 51
31492 20523 3890 19243

Hint

The figure below shows how the Little Cat found out the final order of people in the queue described in the first test case of the sample input.

首先这道题正着来的话会发现每次修改 后面都会依赖前面。并且后面的修改也会影响前面。但是逆着看的话,会发现最后插入的一定是确定的位置,再往前看的话只要保证前面有足够的位置就好了。

(感觉昏昏沉沉啊可能是因为实验室真的太热了!!!!!!太热了太热了!!!!!)

这里线段树 blank【rt】维护的是当前线段所有空闲位置的个数。

注意,当发现左子树没有足够空闲个数的时候,要去看右子树,但是右子树寻找的空闲位置要减去左子树的空闲位置啦,因为blank维护的是线段而不是整个区间。

AC代码

#include <iostream>
#include <cstdio>

#define lson l,m,rt << 1
#define rson m+1,r,rt << 1|1
#define getmid int m = (l + r) >> 1

using namespace std;

const int maxn = 222222;
int blank[maxn << 2];
int d[maxn << 2];
struct Node{
    int cur;
    int data;
};
Node node[222222];

void PushUP(int rt){
    blank[rt] = blank[rt << 1] + blank[rt << 1|1];
    return;
}
void build(int l,int r,int rt){
    blank[rt] = r - l + 1;
    if(l == r) return;
    getmid;
    build(lson);
    build(rson);
    return;
}
void update(int p,int dt,int l,int r,int rt){
    if(l == r){
        blank[rt]--;
        d[rt] = dt;
        return;
    }
    getmid;
    if(blank[rt << 1] >= p){
        update(p,dt,lson);
    }
    else{
        p = p - blank[rt << 1];
        update(p,dt,rson);
    }
    PushUP(rt);
    return;
}
int book;
void print(int l,int r,int rt){
    if(l == r){
        if(book == 0){
            printf("%d",d[rt]);
            book = 1;
        }
        else{
            printf(" %d",d[rt]);
        }

        return;
    }
    getmid;
    print(lson);
    print(rson);
    return;
}
int main() {
    int n;
    while(scanf("%d",&n) != EOF){
        for(int i = 0;i < n;i++){
            scanf("%d%d",&node[i].cur,&node[i].data);
        }
        build(1,n,1);
        for(int i = n-1;i >= 0;i-- ){
            update(node[i].cur+1,node[i].data,1,n,1);
        }
        book = 0;
        print(1,n,1);
        printf("\n");
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_37136305/article/details/81487213