Buy Tickets POJ - 2828 (线段树+思维(逆序))

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/zhangxiaoduoduo/article/details/82874515

                                     Buy Tickets        POJ - 2828 
 

Railway tickets were difficult to buy around the Lunar New Year in China, so we must get up early and join a long queue…

The Lunar New Year was approaching, but unluckily the Little Cat still had schedules going here and there. Now, he had to travel by train to Mianyang, Sichuan Province for the winter camp selection of the national team of Olympiad in Informatics.

It was one o’clock a.m. and dark outside. Chill wind from the northwest did not scare off the people in the queue. The cold night gave the Little Cat a shiver. Why not find a problem to think about? That was none the less better than freezing to death!

People kept jumping the queue. Since it was too dark around, such moves would not be discovered even by the people adjacent to the queue-jumpers. “If every person in the queue is assigned an integral value and all the information about those who have jumped the queue and where they stand after queue-jumping is given, can I find out the final order of people in the queue?” Thought the Little Cat.

Input

There will be several test cases in the input. Each test case consists of N + 1 lines where N (1 ≤ N ≤ 200,000) is given in the first line of the test case. The next N lines contain the pairs of values Posi and Vali in the increasing order of i (1 ≤ i ≤ N). For each i, the ranges and meanings of Posi and Valiare as follows:

  • Posi ∈ [0, i − 1] — The i-th person came to the queue and stood right behind the Posi-th person in the queue. The booking office was considered the 0th person and the person at the front of the queue was considered the first person in the queue.
  • Vali ∈ [0, 32767] — The i-th person was assigned the value Vali.

There no blank lines between test cases. Proceed to the end of input.

Output

For each test cases, output a single line of space-separated integers which are the values of people in the order they stand in the queue.

Sample Input

4
0 77
1 51
1 33
2 69
4
0 20523
1 19243
1 3890
0 31492

Sample Output

77 33 69 51
31492 20523 3890 19243

Hint

The figure below shows how the Little Cat found out the final order of people in the queue described in the first test case of the sample input.

题意:一共有四个位置,第0个后面放77,第1个后面放51,再在第一个后面放33,再在第2个后面放69,输出最后的序列

思路:最开始想暴力,但是肯定TLE。然后看的题解,说线段树,然后用逆序放置。

逆序放置的原因:如果从前开始放,如果插入某个位置,后面的都需要移动。用线段树的话,每个区间存放的是当前区间里的空的位置,从后向前放,假设最后一组输入:2 ,69,说明这个位置前面必定有两个位置,我们只需要在前面空出两个位置,然后在两个空位置之后放上这个即可,放上以后这组数据就不用管了,只需要继续看其他的即可。

手动演示逆序排放:

AC代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<algorithm>
#include<cmath>
#include<utility>
#include<set>
#include<vector>
#include<map>
#include<queue>
#include<stack>
#define maxn 200010
#define INF 0x3f3f3f3f
#define LL long long
#define ULL unsigned long long
#define E 1e-8
#define mod 1000000007
#define P pair<int,int>
#define MID(l,r) (l+(r-l)/2)
#define lson(o) (o<<1) //o*2
#define rson(o) (o<<1|1) //o*2+1
using namespace std;

int a[maxn],b[maxn];
int ans[maxn];

struct node
{
    int l,r,sum;
}tree[maxn<<2];
void build(int o,int l,int r)
{
    tree[o].l = l;
    tree[o].r = r;
    if(l==r){
        tree[o].sum = 1; //当前空位置个数为1
        return ;
    }
    int m = MID(l,r);
    int lc = lson(o),rc = rson(o);
    build(lc,l,m);
    build(rc,m+1,r);
    tree[o].sum  = tree[lc].sum + tree[rc].sum;
}
void update(int o,int p,int v)
{
    if(tree[o].l == tree[o].r){
        ans[tree[o].l] = v;
        tree[o].sum  = 0;     //空位置个数变为0
        return ;
    }
    int lc = lson(o),rc = rson(o);
    if(p<=tree[lc].sum) update(lc,p,v);
    else update(rc,p-tree[lc].sum,v);  //这里要减去左子树的值
    tree[o].sum = tree[lc].sum +tree[rc].sum;
}
int main()
{
    int n;
    while(scanf("%d",&n)!=EOF){
        for(int i=1;i<=n;++i){
            scanf("%d %d",&a[i],&b[i]);
            a[i]++;
        }
        build(1,1,n);
        for(int i=n;i>=1;--i){
            update(1,a[i],b[i]);
        }
        for(int i=1;i<=n;++i){
            printf("%d ",ans[i]);
        }
        printf("\n");
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/zhangxiaoduoduo/article/details/82874515