POJ - 2828 Buy Tickets (线段树♂的用法)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/chenshibo17/article/details/86578317

Railway tickets were difficult to buy around the Lunar New Year in China, so we must get up early and join a long queue…

The Lunar New Year was approaching, but unluckily the Little Cat still had schedules going here and there. Now, he had to travel by train to Mianyang, Sichuan Province for the winter camp selection of the national team of Olympiad in Informatics.

It was one o’clock a.m. and dark outside. Chill wind from the northwest did not scare off the people in the queue. The cold night gave the Little Cat a shiver. Why not find a problem to think about? That was none the less better than freezing to death!

People kept jumping the queue. Since it was too dark around, such moves would not be discovered even by the people adjacent to the queue-jumpers. “If every person in the queue is assigned an integral value and all the information about those who have jumped the queue and where they stand after queue-jumping is given, can I find out the final order of people in the queue?” Thought the Little Cat.

Input

There will be several test cases in the input. Each test case consists of N + 1 lines where N (1 ≤ N ≤ 200,000) is given in the first line of the test case. The next N lines contain the pairs of values Posi and Vali in the increasing order of i(1 ≤ i ≤ N). For each i, the ranges and meanings of Posi and Vali are as follows:

  • Posi ∈ [0, i − 1] — The i-th person came to the queue and stood right behind the Posi-th person in the queue. The booking office was considered the 0th person and the person at the front of the queue was considered the first person in the queue.
  • Vali ∈ [0, 32767] — The i-th person was assigned the value Vali.

There no blank lines between test cases. Proceed to the end of input.

Output

For each test cases, output a single line of space-separated integers which are the values of people in the order they stand in the queue.

Sample Input

4
0 77
1 51
1 33
2 69
4
0 20523
1 19243
1 3890
0 31492

Sample Output

77 33 69 51
31492 20523 3890 19243
#include<cstdio>
#include<iostream>
using namespace std;
const int maxn = 2e5 + 10;
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
int sum[maxn << 2];
int id[maxn];
struct peo {
	int pos,v;
}ple[maxn];
void pushup(int rt) {
	sum[rt] = sum[rt << 1] + sum[rt << 1 | 1];
}
void build(int l, int r, int rt) {
	if (l == r) {
		sum[rt] = 1;
		return ;
	}
	int m = (l + r) >> 1;
	build(lson); build(rson);
	pushup(rt);
}
void query(int pos,int v, int l, int r, int rt ) {
	if (l == r) {
		//cout << "query end:" << pos << " " << v << "-" << l << endl;
		id[l] = v;
		sum[rt] -= 1;
		return;
	}
	int m = (l + r) >> 1;
	if (sum[rt << 1] >= pos) query(pos,v,lson);
	else query(pos - sum[rt << 1], v, rson);
	pushup(rt);
}
int main() {
	int n, cnt;
	while (~scanf("%d", &n)) {
		build(1, n, 1); cnt = 0;
		for (int i = 0; i < n; i++) {
			scanf("%d%d", &ple[i].pos, &ple[i].v);	
			ple[i].pos++;
		}
		for (int i = n - 1; i >= 0; i--) {
			query(ple[i].pos, ple[i].v, 1, n, 1);
		}
		for (int i = 1; i <= n; i++) {
			if (i != 1) {
				printf(" ");
			}
			printf("%d", id[i]);
		}
		printf("\n");
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/chenshibo17/article/details/86578317