POJ 1988 并查集

Farmer John and Betsy are playing a game with N (1 <= N <= 30,000)identical cubes labeled 1 through N. They start with N stacks, each containing a single cube. Farmer John asks Betsy to perform P (1<= P <= 100,000) operation. There are two types of operations: 
moves and counts. 
 * In a move operation, Farmer John asks Bessie to move the stack containing cube X on top of the stack containing cube Y. 
 * In a count operation, Farmer John asks Bessie to count the number of cubes on the stack with cube X that are under the cube X and report that value. 

Write a program that can verify the results of the game. 
Input
* Line 1: A single integer, P 

* Lines 2..P+1: Each of these lines describes a legal operation. Line 2 describes the first operation, etc. Each line begins with a 'M' for a move operation or a 'C' for a count operation. For move operations, the line also contains two integers: X and Y.For count operations, the line also contains a single integer: X. 

Note that the value for N does not appear in the input file. No move operation will request a move a stack onto itself. 
Output
Print the output from each of the count operations in the same order as the input file. 
Sample Input
6
M 1 6
C 1
M 2 4
M 2 6
C 3
C 4
Sample Output
1
0
2
#include<iostream> 
using namespace std;
typedef long long ll;
#define INF 0x3f3f3f3f
#define Max 30010
int f[Max],dis[Max],rank[Max];
void init()
{
	for(int i=0;i<Max;i++)
	{
		f[i]=i;
		dis[i]=0;
		rank[i]=1;
	}
}
int find(int x)
{
	if(x!=f[x])
	{
		int t=f[x];
		f[x]=find(f[x]);
		dis[x]+=dis[t];
	}
	return f[x];
}
int main()
{
	init();
	int n,m,t;
	char c;
	scanf("%d",&n);
    while(n--)
    {
    	cin>>c;
    	if(c=='M')
		{
			 //cin>>m>>t;
		   scanf("%d%d",&m,&t);
		  	int fa=find(m);
			int fb=find(t);
			if(fa!=fb)
			{
				f[fb]=fa;
				dis[fb]+=rank[fa];
				rank[fa]+=rank[fb];
			}   
		}
		else
		{
			scanf("%d",&m);
			int d=find(m);
			printf("%d\n",rank[d]-dis[m]-1);
		} 
    
	}
	
	return 0;
}

猜你喜欢

转载自blog.csdn.net/pinkair/article/details/79775353