kmp循环节 power string

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).
Input
Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.
Output
For each s you should print the largest n such that s = a^n for some string a.
Sample Input
abcd
aaaa
ababab
.
Sample Output
1
4
3
Hint
This problem has huge input, use scanf instead of cin to avoid time limit exceed.

#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cstring>
#include <queue>
#include <map>
using namespace std;
int nex[1000005];
char s[1000005];
int main()
{

    while(scanf("%s", s))
  {
    if( strcmp(s, ".") == 0)
        return 0;
    memset( nex, 0, sizeof( nex ));
    nex[0] = -1;
    int i  = 0;
    int j  = -1;
    int h = strlen( s );
    while( i < h )
    {
        if( j == -1 || s[i] == s[j])
        {
            i++;
            j++;
            nex[i] =  j;
        }
        else
            j = nex[j];
    }
    if( h%( h - nex[h]) == 0)
    printf("%d\n", h/( h-nex[h]));
    else
        printf("1\n");
  }
  return 0;
}

猜你喜欢

转载自blog.csdn.net/jianxingzhang/article/details/79857968