Power Strings(KMP 循环节)

Power Strings

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4
3

Hint

This problem has huge input, use scanf instead of cin to avoid time limit exceed.

代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
#define N 1000005
int len,nex[N];
char s[N];
void getnext()
{
    int k=-1,j=0;
    nex[0]=-1;
    while(j<len)
    {
        if(k==-1||s[j]==s[k]) nex[++j]=++k;
        else k=nex[k];
    }
}
int main()
{
    while(~scanf("%s",s)&&s[0]!='.')
    {
        len=strlen(s);
        getnext();
        int k=len-nex[len];
        if(len%k==0)
        printf("%d\n",len/k);
        else printf("1\n");
    }
    return 0;
}


 

猜你喜欢

转载自blog.csdn.net/chimchim04/article/details/81533750