Backward Digit Sums

FJ and his cows enjoy playing a mental game. They write down the numbers from 1 to N (1 <= N <= 10) in a certain order and then sum adjacent numbers to produce a new list with one fewer number. They repeat this until only a single number is left. For example, one instance of the game (when N=4) might go like this: 
 

    3   1   2   4

      4   3   6

        7   9

         16

Behind FJ's back, the cows have started playing a more difficult game, in which they try to determine the starting sequence from only the final total and the number N. Unfortunately, the game is a bit above FJ's mental arithmetic capabilities. 

Write a program to help FJ play the game and keep up with the cows.

Input

Line 1: Two space-separated integers: N and the final sum.

Output

Line 1: An ordering of the integers 1..N that leads to the given sum. If there are multiple solutions, choose the one that is lexicographically least, i.e., that puts smaller numbers first.

Sample Input

 

4 16

Sample Output

 

3 1 2 4

利用next_-permutation函数

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int a[20];

int n;
int solve()
{int m=n;
int b[20];
for(int i=1;i<=m;i++)
    b[i]=a[i];
    while(m>1)
    {
        for(int i=1;i<=m;i++)
        b[i]=b[i]+b[i+1];
        m--;
    }
    return b[1];
}
int main()
{
    int sum,flag;
    while(~scanf("%d%d",&n,&sum))
    {flag=0;
        for(int i=1;i<=n;i++)
        a[i]=i;
        if(solve()==sum)
        flag=1;
        if(!flag)
        {
            while(next_permutation(a+1,a+n+1))
            if(solve()==sum)
            break;
        }
        for(int i=1;i<n;i++)
        printf("%d ",a[i]);
        printf("%d\n",a[n]);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/sdauguanweihong/article/details/81229137