E - Period (类型5:当前最小循环节中字符串的个数(不可以补字符串))

For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as A K ,that is A concatenated K times, for some string A. Of course, we also want to know the period K.

Input

The input consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S.The second line contains the string S. The input file ends with a line, having the 
number zero on it.

Output

For each test case, output "Test case #" and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.

Sample Input

3
aaa
12
aabaabaabaab
0

Sample Output

Test case #1
2 2
3 3

Test case #2
2 2
6 2
9 3
12 4

题意:如题目中的aabaabaabaab,可分为

aa       (字符串长度:2,循环节:a,次数:2),

aabaab     (字符串长度:6,循环节:aab,次数:2),

aabaabaab     (字符串长度:9,循环节:aab,次数:3),

aabaabaabaab    (字符串长度:12,循环节:aab,次数:4)

弄懂题意就好做了,与类型5相似,多了一层 for 循环

#include<iostream> 
#include<stdio.h>
#include<cstring>
using namespace std;
const int M=1e6+10;
char s[M];
int n;
int nxt[M];
int L;
void kmp(){
	int j=0,i=1;
	nxt[0]=0;
	while(i<L){
		if(s[i]==s[j]){
			nxt[i++]=++j;
		}
		else if(!j){
			i++;
		}
		else{
			j=nxt[j-1];
		}
	}		
}


int main()
{
	int k=1;
	while(cin>>n&&n){
		memset(s,0,sizeof(s));
		memset(nxt,0,sizeof(nxt));//清空!! 
		scanf("%s",s);
		L=strlen(s);
		kmp();
		printf("Test case #%d\n",k++);
		for(int i=1;i<=L;i++){//核心 
			int ans;
			ans=i-nxt[i-1];
			if(i%ans==0&&i/ans>1){
				printf("%d %d\n",i,i/ans);	
			}
		}
		printf("\n");
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41555192/article/details/81813018
今日推荐