1143 Lowest Common Ancestor(30 分)

The lowest common ancestor (LCA) of two nodes U and V in a tree is the deepest node that has both U and V as descendants.

A binary search tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.

Given any two nodes in a BST, you are supposed to find their LCA.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers: M (≤ 1,000), the number of pairs of nodes to be tested; and N (≤ 10,000), the number of keys in the BST, respectively. In the second line, N distinct integers are given as the preorder traversal sequence of the BST. Then M lines follow, each contains a pair of integer keys U and V. All the keys are in the range of int.

Output Specification:

For each given pair of U and V, print in a line LCA of U and V is A. if the LCA is found and A is the key. But if A is one of U and V, print X is an ancestor of Y. where X is A and Y is the other node. If U or V is not found in the BST, print in a line ERROR: U is not found. or ERROR: V is not found. or ERROR: U and V are not found..

Sample Input:

6 8
6 3 1 2 5 4 8 7
2 5
8 7
1 9
12 -3
0 8
99 99

Sample Output:

LCA of 2 and 5 is 3.
8 is an ancestor of 7.
ERROR: 9 is not found.
ERROR: 12 and -3 are not found.
ERROR: 0 is not found.
ERROR: 99 and 99 are not found.

因为查询的数据里有负数,所以要用map来定义一个哈希表

因为根据二叉查找树的性质

左子树上的数据均小于等于根结点, 右子树均大于等于根结点。

题目给出的是先序遍历,即先访问根结点->左子树->右子树。

查询时只要遍历先序序列根据题目要求做条件判断即可

#include<cstdio>
#include<fstream>
#include<vector>
#include<map>
using namespace std;

vector<int> pre;
map<int, bool> hashtable;

int main(){
	int m, n, a;
//	freopen("d://in.txt","r",stdin);
	scanf("%d%d", &m, &n);
	for(int i=0; i<n; i++){
		scanf("%d", &a);
		pre.push_back(a);
		hashtable[pre[i]]=true;
	}
	int u, v, x;
	for(int i=0; i<m; i++){
		scanf("%d%d", &u, &v);
		for(int j=0; j<n; j++){
			x=pre[j];
			if((x>=u && x<=v) || (x<=u && x>=v)) break;
		}
		if(hashtable[u]==0 && hashtable[v]==0){
			printf("ERROR: %d and %d are not found.\n", u, v);
		} else if(hashtable[u]==0){
			printf("ERROR: %d is not found.\n", u);
		} else if(hashtable[v]==0){
			printf("ERROR: %d is not found.\n", v);
		} else if(x==u){
			printf("%d is an ancestor of %d.\n", u, v);
		} else if(x==v){
			printf("%d is an ancestor of %d.\n", v, u);
		} else{
			printf("LCA of %d and %d is %d.\n", u, v, x);
		}
	}
	return 0;
}
扫描二维码关注公众号,回复: 3069050 查看本文章

猜你喜欢

转载自blog.csdn.net/Chuyuan_li/article/details/82195138