1143. Lowest Common Ancestor (30)

The lowest common ancestor (LCA) of two nodes U and V in a tree is the deepest node that has both U and V as descendants.

A binary search tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.

Given any two nodes in a BST, you are supposed to find their LCA.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers: M (<= 1000), the number of pairs of nodes to be tested; and N (<= 10000), the number of keys in the BST, respectively. In the second line, N distinct integers are given as the preorder traversal sequence of the BST. Then M lines follow, each contains a pair of integer keys U and V. All the keys are in the range of int.

Output Specification:

For each given pair of U and V, print in a line "LCA of U and V is A." if the LCA is found and A is the key. But if A is one of U and V, print "X is an ancestor of Y." where X is A and Y is the other node. If U or V is not found in the BST, print in a line "ERROR: U is not found." or "ERROR: V is not found." or "ERROR: U and V are not found.".

Sample Input:
6 8
6 3 1 2 5 4 8 7
2 5
8 7
1 9
12 -3
0 8
99 99
Sample Output:
LCA of 2 and 5 is 3.
8 is an ancestor of 7.
ERROR: 9 is not found.
ERROR: 12 and -3 are not found.
ERROR: 0 is not found.
ERROR: 99 and 99 are not found.


建树有两种方法,一种是把前序遍历从小到大排序就是中序遍历,然后根据前中序遍历建树。注释部分。
另一种是直接用前序遍历建树。其实中序遍历就是助于判断左右子树,用前序遍历就可以单独判断左右子树的。
代码:
#include <iostream>
#include <cstdio>
#include <algorithm>
#include <map>
using namespace std;
struct tree
{
    int Data,Height;
    tree *Last,*Left,*Right;
}*head;
int q[10001],z[10001],m,n;
map<int,tree *> mp;
tree *createNode(int d,int h)
{
    tree *p = new tree();
    p -> Data = d;
    mp[d] = p;
    p -> Height = h;
    p -> Last = p -> Left = p -> Right = NULL;
    return p;
}
tree *createTree(int ql,int qr,int zl,int zr,int h)
{
    tree *p = createNode(q[ql],h);
    for(int i = zl;i <= zr;i ++)
    {
        if(z[i] == q[ql])
        {
            if(i > zl)p -> Left = createTree(ql + 1,ql + i - zl,zl,i - 1,h + 1),p -> Left -> Last = p;
            if(i < zr)p -> Right = createTree(ql + i - zl + 1,qr,i + 1,zr,h + 1),p -> Right -> Last = p;
            break;
        }
    }
    return p;
}
tree *createTre(int l,int r,int h)
{
    tree *p = createNode(q[l],h);
    for(int i = l + 1;i <= r + 1;i ++)
    {
        if(i == r + 1 || q[i] >= q[l])
        {
            if(i > l + 1)p -> Left = createTre(l + 1,i - 1,h + 1),p -> Left -> Last = p;
            if(r >= i)p -> Right = createTre(i,r,h + 1),p -> Right -> Last = p;
            return p;
        }
    }
}
void check(int a,int b)
{
    if(mp[a] == NULL && mp[b] == NULL)printf("ERROR: %d and %d are not found.\n",a,b);
    else if(mp[a] == NULL)printf("ERROR: %d is not found.\n",a);
    else if(mp[b] == NULL)printf("ERROR: %d is not found.\n",b);
    else
    {
        tree *t1 = mp[a],*t2 = mp[b];
        while(t1 -> Height != t2 -> Height)
        {
            if(t1 -> Height > t2 -> Height)t1 = t1 -> Last;
            else t2 = t2 -> Last;
        }
        if(t1 == t2)
        {
            printf("%d is an ancestor of %d.\n",t1 -> Data,a == t1 -> Data ? b : a);
            return;
        }
        t1 = t1 -> Last;
        t2 = t2 -> Last;
        while(t1 != t2)
        {
            t1 = t1 -> Last;
            t2 = t2 -> Last;
        }
        printf("LCA of %d and %d is %d.\n",a,b,t1 -> Data);
    }
}
int main()
{
    int a,b;
    scanf("%d%d",&m,&n);
    for(int i = 0;i < n;i ++)
    {
        scanf("%d",&q[i]);
        //z[i] = q[i];
    }
    //sort(z,z + n);
//    head = createTree(0,n - 1,0,n - 1,0);
    head = createTre(0,n - 1,0);
    for(int i = 0;i < m;i ++)
    {
        scanf("%d%d",&a,&b);
        check(a,b);
    }
}

猜你喜欢

转载自www.cnblogs.com/8023spz/p/8976489.html