1143 Lowest Common Ancestor (30 分)

版权声明:文章都是原创,转载请注明~~~~ https://blog.csdn.net/SourDumplings/article/details/86561694

The lowest common ancestor (LCA) of two nodes U and V in a tree is the deepest node that has both U and V as descendants.

A binary search tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.

Given any two nodes in a BST, you are supposed to find their LCA.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers: M (≤ 1,000), the number of pairs of nodes to be tested; and N (≤ 10,000), the number of keys in the BST, respectively. In the second line, N distinct integers are given as the preorder traversal sequence of the BST. Then M lines follow, each contains a pair of integer keys U and V. All the keys are in the range of int.

Output Specification:

For each given pair of U and V, print in a line LCA of U and V is A. if the LCA is found and A is the key. But if A is one of U and V, print X is an ancestor of Y. where X is A and Y is the other node. If U or V is not found in the BST, print in a line ERROR: U is not found. or ERROR: V is not found. or ERROR: U and V are not found..

Sample Input:

6 8
6 3 1 2 5 4 8 7
2 5
8 7
1 9
12 -3
0 8
99 99

Sample Output:

LCA of 2 and 5 is 3.
8 is an ancestor of 7.
ERROR: 9 is not found.
ERROR: 12 and -3 are not found.
ERROR: 0 is not found.
ERROR: 99 and 99 are not found.

C++:

/*
 @Date    : 2018-08-04 21:46:12
 @Author  : 酸饺子 ([email protected])
 @Link    : https://github.com/SourDumplings
 @Version : $Id$
*/

/*
https://pintia.cn/problem-sets/994805342720868352/problems/994805343727501312
 */

#include <iostream>
#include <cstdio>
#include <vector>
#include <algorithm>
#include <set>

using namespace std;

struct BST
{
    int key;
    BST *left = nullptr, *right = nullptr;
};

const int MAXN = 10005;
int data[MAXN];
int m, n;
set<int> nodes;

BST* build_tree(int b, int e)
{
    if (e == b)
    {
        return nullptr;
    }

    BST *r = new BST;
    r->key = data[b];
    nodes.insert(r->key);
    if (b + 1 == e)
    {
        return r;
    }

    int right = e;
    for (int i = b + 1; i < e; ++i)
    {
        if (data[i] >= r->key)
        {
            right = i;
            break;
        }
    }

    r->left = build_tree(b+1, right);
    r->right = build_tree(right, e);
    return r;
}

void search_LCA(BST *r, int u, int v)
{
    if (r->key == u)
    {
        printf("%d is an ancestor of %d.\n", u, v);
    }
    else if (r->key == v)
    {
        printf("%d is an ancestor of %d.\n", v, u);
    }
    else
    {
        if ((r->key < u && r->key > v) || (r->key < v && r->key > u))
        {
            printf("LCA of %u and %d is %d.\n", u, v, r->key);
        }
        else if (r->key < v && r->key < u)
        {
            return search_LCA(r->right, u, v);
        }
        else
            return search_LCA(r->left, u, v);
    }
    return;
}

int main(int argc, char const *argv[])
{
    scanf("%d %d", &m, &n);
    for (int i = 0; i < n; ++i)
    {
        scanf("%d", &data[i]);
    }

    BST *T = build_tree(0, n);

    for (int i = 0; i < m; ++i)
    {
        int u, v;
        scanf("%d %d", &u, &v);
        if (nodes.find(u) == nodes.end())
        {
            if (nodes.find(v) == nodes.end())
            {
                printf("ERROR: %d and %d are not found.\n", u, v);
            }
            else
            {
                printf("ERROR: %d is not found.\n", u);
            }
        }
        else if (nodes.find(v) == nodes.end())
        {
            printf("ERROR: %d is not found.\n", v);
        }
        else
        {
            search_LCA(T, u, v);
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/SourDumplings/article/details/86561694