1143 Lowest Common Ancestor (30分)

The lowest common ancestor (LCA) of two nodes U and V in a tree is the deepest node that has both U and V as descendants.

A binary search tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.

Given any two nodes in a BST, you are supposed to find their LCA.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers: M (≤1,000), the number of pairs of nodes to be tested; and N (≤ 10,000), the number of keys in the BST, respectively. In the second line, N distinct integers are given as the preorder traversal sequence of the BST. Then M lines follow, each contains a pair of integer keys U and V. All the keys are in the range of int.

Output Specification:

For each given pair of U and V, print in a line LCA of U and V is A. if the LCA is found and A is the key. But if A is one of U and V, print X is an ancestor of Y. where X is A and Y is the other node. If U or V is not found in the BST, print in a line ERROR: U is not found. or ERROR: V is not found. or ERROR: U and V are not found..

Sample Input:

6 8
6 3 1 2 5 4 8 7
2 5
8 7
1 9
12 -3
0 8
99 99

Sample Output:

LCA of 2 and 5 is 3.
8 is an ancestor of 7.
ERROR: 9 is not found.
ERROR: 12 and -3 are not found.
ERROR: 0 is not found.
ERROR: 99 and 99 are not found.
#include<iostream>
#include<algorithm>
#include<vector>
#include<unordered_set>
using namespace std;

int main(){
    int m, n;
    cin >> m >> n;
    vector<int> preorder(n);
    unordered_set<int> un_set;
    for(int i = 0; i < n; i++){

        scanf("%d", &preorder[i]);
        un_set.insert(preorder[i]);

    }
    for(int i = 0; i < m; i++){
        int temp_a, temp_b;
        scanf("%d %d", &temp_a, &temp_b);
        
        int ancestor;
        int count = 0;
        if(un_set.find(temp_a) == un_set.end() || un_set.find(temp_b) == un_set.end()){

            if(un_set.find(temp_a) == un_set.end() && un_set.find(temp_b) == un_set.end()){

                printf("ERROR: %d and %d are not found.\n", temp_a, temp_b);

            }else if(un_set.find(temp_a) == un_set.end() && un_set.find(temp_b) != un_set.end()){

                printf("ERROR: %d is not found.\n", temp_a);

            }else
            {
                printf("ERROR: %d is not found.\n", temp_b);
            }
            


        }else
        {
            for(int j = 0; j < n; j++){

                if(preorder[j] == temp_a)
                    count++;
                if(preorder[j] == temp_b)
                    count++;

                if(count <= 2){

                    // if(preorder[j] >= temp_a && preorder[j] >= temp_b && preorder[j] != min(temp_a, temp_b)){
                        
    
                    //     ancestor = preorder[j];

                    // }
                    // if(preorder[j] <= temp_a && preorder[j] <= temp_b && preorder[j] != min(temp_a, temp_b)){
                        
                    //     ancestor = preorder[j];
                    // }

                    if((((preorder[j] < temp_a)  && (preorder[j] > temp_b))) || (((preorder[j] > temp_a)  && (preorder[j] < temp_b))) || preorder[j] == temp_b || preorder[j] == temp_a){
                        
                        ancestor = preorder[j];
                        break;



                    }

                }


            }
            if(ancestor == temp_b || ancestor == temp_a){

                printf("%d is an ancestor of %d.\n", ancestor, ancestor == temp_a ? temp_b : temp_a);
            
            }else
            {
                printf("LCA of %d and %d is %d.\n", temp_a, temp_b, ancestor);
            }
            
            


        }
        


    }


    return 0;
}
发布了38 篇原创文章 · 获赞 0 · 访问量 533

猜你喜欢

转载自blog.csdn.net/zbchenchanghao/article/details/104080908