Machine Schedule(POJ 1325)

Description

As we all know, machine scheduling is a very classical problem in computer science and has been studied for a very long history. Scheduling problems differ widely in the nature of the constraints that must be satisfied and the type of schedule desired. Here we consider a 2-machine scheduling problem. 

There are two machines A and B. Machine A has n kinds of working modes, which is called mode_0, mode_1, ..., mode_n-1, likewise machine B has m kinds of working modes, mode_0, mode_1, ... , mode_m-1. At the beginning they are both work at mode_0. 

For k jobs given, each of them can be processed in either one of the two machines in particular mode. For example, job 0 can either be processed in machine A at mode_3 or in machine B at mode_4, job 1 can either be processed in machine A at mode_2 or in machine B at mode_4, and so on. Thus, for job i, the constraint can be represent as a triple (i, x, y), which means it can be processed either in machine A at mode_x, or in machine B at mode_y. 

Obviously, to accomplish all the jobs, we need to change the machine's working mode from time to time, but unfortunately, the machine's working mode can only be changed by restarting it manually. By changing the sequence of the jobs and assigning each job to a suitable machine, please write a program to minimize the times of restarting machines. 

Input

The input file for this program consists of several configurations. The first line of one configuration contains three positive integers: n, m (n, m < 100) and k (k < 1000). The following k lines give the constrains of the k jobs, each line is a triple: i, x, y. 

The input will be terminated by a line containing a single zero. 

Output

The output should be one integer per line, which means the minimal times of restarting machine.

Sample Input

5 5 10
0 1 1
1 1 2
2 1 3
3 1 4
4 2 1
5 2 2
6 2 3
7 2 4
8 3 3
9 4 3
0

Sample Output

3

不得不说,二分图匹配的题总是隐藏的很好,我一上来看是贪心题

给你两台机器A,B,分别有 n ,m 种模式,做 k 个任务

某个任务只能由 A 的 a[i] 模式 或 B 的 b[i] 模式做,我们建一个 a[i] -> b[i] 的二分图

如图,每条边相当于一个任务

我们先把 a:1 匹配上 b:1,当 a:2 匹配 b:1  时意味着什么?

扫描二维码关注公众号,回复: 3510766 查看本文章

说明该做任务 a 必须要切换下模式,或是 b 切换(开启)

到了 a: 3 ,同理,要再切换一次

到了 a: 4 ,可以理解为上一步开启了 b: 3 ,所以就直接由它做了

 

以前我以为匈牙利只是最大边匹配,现在明白了它等同于最小点覆盖(切换次数)>:<

code

#include<stdio.h>
#include<string.h>
#include<algorithm> 
using namespace std;
const int MX=1001;
int n,m,k,match[MX];
bool vis[MX],f[MX][MX];

bool hungry(int u) 
{
    for(int i=1;i<=m;++i) {
        if(f[u][i]) {
            if(vis[i]) continue;
            vis[i]=1;
            if(!match[i] || hungry(match[i])) {
                match[i]=u;
                return 1;
            }
        }
    }
    return 0;
}

int main() 
{
    while(scanf("%d",&n)!=EOF && n) {
        memset(f,0,sizeof(f));
        memset(match,0,sizeof(match));
        scanf("%d%d",&m,&k);
        while(k--) {
            int i,u,v;
            scanf("%d%d%d",&i,&u,&v);
            f[u][v]=1;
        }
        int ans=0;
        for(int i=1;i<=n;++i) {
            memset(vis,0,sizeof(vis));
            ans+=hungry(i);
        }
        printf("%d\n",ans);
    }
    return 0;
}

猜你喜欢

转载自www.cnblogs.com/qseer/p/9765696.html