[POJ1325]Machine Schedule 任务安排

版权声明:本文为博主原创文章,转载请注明本页地址。 https://blog.csdn.net/C20180630/article/details/70209929

Description

As we all know, machine scheduling is a very classical problem in computer science and has been studied for a very long history. Scheduling problems differ widely in the nature of the constraints that must be satisfied and the type of schedule desired. Here we consider a 2-machine scheduling problem.

There are two machines A and B. Machine A has n kinds of working modes, which is called mode_0, mode_1, …, mode_n-1, likewise machine B has m kinds of working modes, mode_0, mode_1, … , mode_m-1. At the beginning they are both work at mode_0.

For k jobs given, each of them can be processed in either one of the two machines in particular mode. For example, job 0 can either be processed in machine A at mode_3 or in machine B at mode_4, job 1 can either be processed in machine A at mode_2 or in machine B at mode_4, and so on. Thus, for job i, the constraint can be represent as a triple (i, x, y), which means it can be processed either in machine A at mode_x, or in machine B at mode_y.

Obviously, to accomplish all the jobs, we need to change the machine’s working mode from time to time, but unfortunately, the machine’s working mode can only be changed by restarting it manually. By changing the sequence of the jobs and assigning each job to a suitable machine, please write a program to minimize the times of restarting machines.

Input

The input file for this program consists of several configurations. The first line of one configuration contains three positive integers: n, m (n, m < 100) and k (k < 1000). The following k lines give the constrains of the k jobs, each line is a triple: i, x, y.

The input will be terminated by a line containing a single zero.

Output

The output should be one integer per line, which means the minimal times of restarting machine.

Sample Input

5 5 10
0 1 1
1 1 2
2 1 3
3 1 4
4 2 1
5 2 2
6 2 3
7 2 4
8 3 3
9 4 3
0

Sample Output

3

题目大意

有两台机器A和B及K个需要运行的任务。A机器有M种不同的模式,B机器有M种运行模式。而每个任务i都恰好在一台机器上运行。如果它在机器A上运行,则机器A需要设置为模式ai,如果它在机器B上运行,则机器B需要设置为模式bi,ai不一定等于bi。每台机器上的任务可以按照任意顺序执行,但是每台机器每转换一次模式需要重新启动一次。最开始两台机器都设置为模式0.请合理为每个任务安排一台机器并合理安排顺序,使得机器重启次数尽量少。

分析

因为最开始的两台机器都设置为模式0,所以为模式0的工作可以无代价的完成,所以可以筛掉。
然后将A机器的每个模式看成一个X结点,B机器的每个模式看成一个Y结点,任务i为边(ai,bi),构造二分图。
二分图
转变为图(2)之后发现,之前的job一定在图2中的某一条边上,同一条边上可以包含多个job,所以要完成所有的job,只需要包含所有的边即可。
本题即为求最少的点让每条边都至少和其中的一个点关联(X部或Y部均可),这就是二分图的最小点覆盖问题。
有以下结论:最少点数(称为覆盖数)就是最大匹配数M

扫描二维码关注公众号,回复: 3823166 查看本文章

源代码

#include<cstdio>
#include<cstring>
#include<iostream>
using namespace std;
int map[1001][1001],vis[1001],link[1001];
int n,m,k;
void getint(int &p){
    int flag=1;char ch;
    for(p=0;ch>'9'||ch<'0';ch=getchar())if(ch=='-') flag=-1;
    for(;ch<='9'&&ch>='0';ch=getchar())p=p*10+ch-'0';
    p*=flag;
}
int find(int x){
    int i;
    for(i=1;i<=m;i++)
        if(map[x][i]&&!vis[i]){
            vis[i]=1;
            if(!link[i]||find(link[i])){
                link[i]=x;
                return 1;
            }
        }
    return 0;
}
int main()
{
    while(~scanf("%d",&n)&&n){
        getint(m);getint(k);int sum=0;
        memset(map,0,sizeof map);
        memset(link,0,sizeof link);
        while(k--){
            int a,b,c;
            getint(a);getint(b);getint(c);
            if(b*c) map[b][c]=1;
        }
        for(int i=1;i<=n;i++){
            memset(vis,0,sizeof(vis));
            if(find(i))
                sum++;
        }
        printf("%d\n",sum);
    }
}

猜你喜欢

转载自blog.csdn.net/C20180630/article/details/70209929