Machine Schedule 6.3.3

Machine Schedule

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 99    Accepted Submission(s): 66


 

Problem Description
As we all know, machine scheduling is a very classical problem in computer science and has been studied for a very long history. Scheduling problems differ widely in the nature of the constraints that must be satisfied and the type of schedule desired. Here we consider a 2-machine scheduling problem.

There are two machines A and B. Machine A has n kinds of working modes, which is called mode_0, mode_1, …, mode_n-1, likewise machine B has m kinds of working modes, mode_0, mode_1, … , mode_m-1. At the beginning they are both work at mode_0.

For k jobs given, each of them can be processed in either one of the two machines in particular mode. For example, job 0 can either be processed in machine A at mode_3 or in machine B at mode_4, job 1 can either be processed in machine A at mode_2 or in machine B at mode_4, and so on. Thus, for job i, the constraint can be represent as a triple (i, x, y), which means it can be processed either in machine A at mode_x, or in machine B at mode_y.

Obviously, to accomplish all the jobs, we need to change the machine's working mode from time to time, but unfortunately, the machine's working mode can only be changed by restarting it manually. By changing the sequence of the jobs and assigning each job to a suitable machine, please write a program to minimize the times of restarting machines.
Input
The input file for this program consists of several configurations. The first line of one configuration contains three positive integers: n, m (n, m < 100) and k (k < 1000). The following k lines give the constrains of the k jobs, each line is a triple: i, x, y.

The input will be terminated by a line containing a single zero.
Output
The output should be one integer per line, which means the minimal times of restarting machine.
Sample Input
5 5 10
0 1 1
1 1 2
2 1 3
3 1 4
4 2 1
5 2 2
6 2 3
7 2 4
8 3 3
9 4 3
0
Sample Output
3
 
题意是将一项任务安排到a或者b机器上,使得尽量少的换挡,完成所有任务,机器刚开始在0档。
每一项任务相当于在a, b之间连一条边,使用尽量少的点覆盖这些边。
 
 
      
#include<cstdio>
#include<cstring>
using namespace std;

const int MAXN = 100 + 10;
int g[MAXN][MAXN], done[MAXN], link[MAXN];
int n, m, k;
bool find_match(int i){
	for(int j = 1; j < m; j++){
		if(g[i][j] && !done[j]){
			done[j] = 1;
			if(link[j] == -1 || find_match(link[j])){
				link[j] = i;
				return true;
			}
		}
	}
	return false;
}
int main(){
	int u, v, x;
	while(scanf("%d", &n) && n){
		memset(g, 0, sizeof(g));
		scanf("%d%d", &m, &k);
		for(int i = 0; i < k; i++){
			scanf("%d%d%d", &x, &u, &v);
			if(u && v) g[u][v] = 1;
		}
		int cnt = 0;
		memset(link, -1, sizeof(link));
		for(int i = 1; i < n; i++){
			memset(done, 0, sizeof(done));
			if(find_match(i)) cnt++;
		}
		printf("%d\n", cnt);
	}
	return 1;
}

猜你喜欢

转载自blog.csdn.net/bruce_teng2011/article/details/38589833