【链表】有序链表的归并

题目:分别输入两个有序的整数序列(分别包含M和N个数据),建立两个有序的单链表,将这两个有序单链表合并成为一个大的有序单链表,并依次输出合并后的单链表数据。

第一行输入M与N的值;第二行依次输入M个有序的整数;第三行依次输入N个有序的整数。

输出合并后的单链表所包含的M+N个有序的整数。

Sample Input

6 5
1 23 26 45 66 99
14 21 28 50 100

Sample Output

1 14 21 23 26 28 45 50 66 99 100
#include <stdio.h>
#include <stdlib.h>
struct node
{
    int data;
    struct node *next;
};
struct node *creat(int x)
{
    struct node *head,*tail,*p;
    head=(struct node*)malloc(sizeof(struct node));
    head->next=NULL;
    tail=head;
    while(x--)
    {
        p=(struct node*)malloc(sizeof(struct node));
        scanf("%d",&p->data);
        p->next=NULL;
        tail->next=p;
        tail=p;
    }
    return head;
};
struct node *gb(struct node *head1,struct node *head2)
{
    struct node *p1,*p2,*q1,*q2,*tail;
    p1=head1->next;
    p2=head2->next;
    tail=head1;
    free(head2);
    while(p1&&p2)
    {
        if(p1->data<=p2->data)
        {
            tail->next=p1;
            tail=p1;
            p1=p1->next;
            //tail->next=NULL;//aaaaaaaaaaaaaaaaaaaaaaa
        }
        else
        {
            tail->next=p2;
            tail=p2;
            p2=p2->next;
            //tail->next=NULL;
        }
    }
    if(p1)
        tail->next=p1;
    else if(p2)
        tail->next=p2;
    return head1;
};
int main()
{
    int n,m;
    struct node *head,*head1,*head2,*p;
    scanf("%d%d",&m,&n);
    head1=creat(m);
    head2=creat(n);
    head=gb(head1,head2);
    p=head->next;
    while(p)
    {
        printf("%d",p->data);
        if(p->next)
            printf(" ");
        else printf("\n");
        p=p->next;//bbbbbb
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/flyf000/article/details/82945766