Fibonacci POJ 3070

Fibonacci POJ 3070

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 10096 Accepted: 7208

Description

In the Fibonacci integer sequence, F0 = 0, F1 = 1, and Fn = Fn − 1 + Fn − 2 for n ≥ 2. For example, the first ten terms of the Fibonacci sequence are:

0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …

An alternative formula for the Fibonacci sequence is

.

Given an integer n, your goal is to compute the last 4 digits of Fn.

Input

The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤ n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number −1.

Output

For each test case, print the last four digits of Fn. If the last four digits of Fn are all zeros, print ‘0’; otherwise, omit any leading zeros (i.e., print Fn mod 10000).

扫描二维码关注公众号,回复: 6113655 查看本文章

Sample Input

0
9
999999999
1000000000
-1

Sample Output

0
34
626
6875

Hint

As a reminder, matrix multiplication is associative, and the product of two 2 × 2 matrices is given by
.
Also, note that raising any 2 × 2 matrix to the 0th power gives the identity matrix:
快速求斐波那契的新方法

#include<bits/stdc++.h>
using namespace std;
const int MOD = 10000;
struct matrix
 {		                                      //矩阵 
	int m[2][2];
}ans;
 
matrix base = {1, 1, 1, 0}; 
 
matrix multi(matrix a, matrix b)  //矩阵相乘,返回一个矩阵 
{	
	matrix tmp;
	for(int i = 0; i < 2; i++) {
		for(int j = 0; j < 2; j++) {
			tmp.m[i][j] = 0;
			for(int k = 0;  k < 2; k++)
				tmp.m[i][j] = (tmp.m[i][j] + a.m[i][k] * b.m[k][j]) % MOD;
		}
	}
	return tmp;
}
 
int matrix_pow(matrix a, int n) {	//矩阵快速幂,矩阵a的n次幂 
	ans.m[0][0] = ans.m[1][1] = 1;	//初始化为单位矩阵 
	ans.m[0][1] = ans.m[1][0] = 0;
	while(n) {
		if(n & 1) ans = multi(ans, a);
		a = multi(a, a);
		n >>= 1;
	}
	return ans.m[0][1];
}
 
int main() {
	int n;
	while(scanf("%d", &n), n != -1) {
		printf("%d\n", matrix_pow(base, n));
	}
	return 0;
} 

模板

struct matrix//定义一个结构体,方便传递值
{
int m[maxn][maxn];
};

/*
maxn和mod由全局定义,其中mod根据需要可以省去
*/

matrix mat_multi(matrix a, matrix b)//矩阵求积
{
matrix ans;
for(int i = 0;i < maxn;i++)
{
for(int j = 0;j < maxn;j++)
{
ans.m[i][j] = 0;
for(int k = 0;k < maxn;k++)
{
ans.m[i][j] += (a.m[i][k] % mod * b.m[k][j] % mod) % mod;
ans.m[i][j] %= mod;
}
}
}
return ans;
}

matrix mat_quickpow(matrix a, int n)//矩阵快速幂
{
matrix ans;
for(int i = 0;i < maxn;i++)
{
for(int j = 0;j < maxn;j++)
{
if(i == j)
ans.m[i][j] = 1;
else
ans.m[i][j] = 0;//这里要初始化为单位矩阵,类比普通快速幂这里初始化为1
}
}
while(n != 0)//方法与普通快速幂相同,只有乘法的实现不同
{
if(n & 1)
ans = mat_multi(a, ans);
a = mat_multi(a, a);
n >>= 1;
}
return ans;
}

猜你喜欢

转载自blog.csdn.net/king9666/article/details/89810867