poj3070- Fibonacci

Description

In the Fibonacci integer sequence, F0 = 0, F1 = 1, and Fn = Fn − 1 + Fn − 2 for n ≥ 2. For example, the first ten terms of the Fibonacci sequence are:

0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …

An alternative formula for the Fibonacci sequence is

.

Given an integer n, your goal is to compute the last 4 digits of Fn.

Input

The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤ n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number −1.

Output

For each test case, print the last four digits of Fn. If the last four digits of Fn are all zeros, print ‘0’; otherwise, omit any leading zeros (i.e., print Fn mod 10000).

Sample Input

0
9
999999999
1000000000
-1

Sample Output

0
34
626
6875

Hint

As a reminder, matrix multiplication is associative, and the product of two 2 × 2 matrices is given by

.

Also, note that raising any 2 × 2 matrix to the 0th power gives the identity matrix:

.

题目链接:http://poj.org/problem?id=3070

矩阵快速幂模板题

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;

const int mod = 1e4;
 
struct matrix{
    long long int m[2][2];
};

matrix multi(matrix a, matrix b){
    matrix ans;
    ans.m[0][0] = (a.m[0][0]*b.m[0][0]+a.m[0][1]*b.m[1][0])%mod;
    ans.m[0][1] = (a.m[0][0]*b.m[0][1]+a.m[0][1]*b.m[1][1])%mod;
    ans.m[1][0] = (a.m[1][0]*b.m[0][0]+a.m[1][1]*b.m[1][0])%mod;
    ans.m[1][1] = (a.m[1][0]*b.m[0][1]+a.m[1][1]*b.m[1][1])%mod;
    return ans;
}

 int matrixpow_k(int n)
 {
    matrix ans, tmp;
    ans.m[0][0] = ans.m[1][1] = tmp.m[0][0] = tmp.m[0][1] = tmp.m[1][0] = 1;
    ans.m[0][1] = ans.m[1][0] = tmp.m[1][1] = 0;
    n -= 2;
    while(n)
    {
        if(n & 1)
            ans = multi(tmp,ans);
        tmp = multi(tmp, tmp);
        n >>= 1;
    }
    int s = (ans.m[0][0]+ans.m[0][1]) % mod;
    return s;
}

int main()
{
    int n;
    while(cin >> n)
    {
        if(n == -1)
            break;
        if(n == 0)
        {
            cout << 0 << endl;
            continue;
        } 
        else if(n==1 || n==2)
        {
            cout << 1 << endl;
            continue;
        }
        cout <<    matrixpow_k(n) << endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_38295645/article/details/81742032