oj1272: Herd Sums

题目要求
The cows in farmer John’s herd are numbered and branded with consecutive integers from 1 to N (1 <= N <= 10,000,000). When the cows come to the barn for milking, they always come in sequential order from 1 to N.

Farmer John, who majored in mathematics in college and loves numbers, often looks for patterns. He has noticed that when he has exactly 15 cows in his herd, there are precisely four ways that the numbers on any set of one or more consecutive cows can add up to 15 (the same as the total number of cows). They are: 15, 7+8, 4+5+6, and 1+2+3+4+5.

When the number of cows in the herd is 10, the number of ways he can sum consecutive cows and get 10 drops to 2: namely 1+2+3+4 and 10.

Write a program that will compute the number of ways farmer John can sum the numbers on consecutive cows to equal N. Do not use precomputation to solve this problem.
Input

  • Line 1: A single integer: N
    Output
  • Line 1: A single integer that is the number of ways consecutive cow brands can sum to N.
    Sample Input
    Raw
    15
    Sample Output
    Raw
    4
    简单来说就是看一个数是哪些数字不断累加,如10为1 + 2 + 3 + 4和10,结果为2.
    从后往前不断遍历,寻找上一个数和该数的累加,知道超过或等于袁术n
    完整代码
#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
#include<queue>
#include<math.h>
#include<stdio.h>
#include<string.h>
using namespace std;
int main()
{
	int n, sum = 0, i, r = 0, k;
	cin>>n;
	k = n;
	for (i = n; i >= 1; i--)
	{
		sum += i;
		if (sum == n)
			r++;
		else if (sum > n)
			sum -= k--;
	}
	cout<<r<<endl;
	return 0;
}
发布了38 篇原创文章 · 获赞 27 · 访问量 3183

猜你喜欢

转载自blog.csdn.net/qq_45891413/article/details/104933337