南阳ID:122 Triangular Sums

Triangular Sums

时间限制: 3000 ms  |  内存限制: 65535 KB
难度: 2
描述

The nth Triangular number, T(n) = 1 + … + n, is the sum of the first n integers. It is the number of points in a triangular array with n points on side. For example T(4):

X
X X
X X X
X X X X

Write a program to compute the weighted sum of triangular numbers:

W(n) = SUM[k = 1…nk * T(k + 1)]

输入
The first line of input contains a single integer N, (1 ≤ N ≤ 1000) which is the number of datasets that follow.

Each dataset consists of a single line of input containing a single integer n, (1 ≤ n ≤300), which is the number of points on a side of the triangle.
输出
For each dataset, output on a single line the dataset number (1 through N), a blank, the value of n for the dataset, a blank, and the weighted sum ,W(n), of triangular numbers for n.
样例输入
4
3
4
5
10
样例输出
1 3 45
2 4 105
3 5 210
4 10 2145
#include<stdio.h>
int sum(int a)
{
    int b=0,i;
    for(i=1;i<=a;i++)
    {
        b+=i;
    }
    return b;
}
int f(int n)
{
    int sum1=0;
    int i;
    for(i=1;i<=n;i++)
    {
        sum1+=i*sum(i+1);
    }
    return sum1;
}
int main()
{
    int n,t;
    int i=1;
    scanf("%d",&n);
    while(n--)
    {
        scanf("%d",&t);
        printf("%d %d %d\n",i,t,f(t));
        i++;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_36664584/article/details/75319153