1001 A+B Format (20point(s))

Calculate a+b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:

Each input file contains one test case. Each case contains a pair of integers a and b where −10​6​​≤a,b≤10​6​​. The numbers are separated by a space.

Output Specification:

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:

-1000000 9

Sample Output:

-999,991

Example:

#include <iostream>
#include <stack>

using namespace std;

int main()
{
    int a, b;
    cin >> a >> b;
    int c = a + b;
    if(c == 0) {
        cout << 0;
    } else {
        cout << (c > 0 ? "" : "-");
        c = (c > 0 ? c : -c);
        stack<char> s;
        int i = 0;
        while(c) {
            s.push(c % 10 + '0');
            c /= 10;
            ++i;
            if(c && i % 3 == 0) s.push(',');
        }
        while(!s.empty()) {
            cout << s.top();
            s.pop();
        }
    }
    return 0;
}

思路:

 利用入栈,出栈操作将结果输出。

猜你喜欢

转载自blog.csdn.net/u012571715/article/details/113484933
今日推荐