A - Rescue(广度优先搜索BFS)

A - Rescue

 Angel was caught by the MOLIGPY! He was put in prison by Moligpy. The prison is described as a N * M (N, M <= 200) matrix. There are WALLs, ROADs, and GUARDs in the prison. 

Angel's friends want to save Angel. Their task is: approach Angel. We assume that "approach Angel" is to get to the position where Angel stays. When there's a guard in the grid, we must kill him (or her?) to move into the grid. We assume that we moving up, down, right, left takes us 1 unit time, and killing a guard takes 1 unit time, too. And we are strong enough to kill all the guards. 

You have to calculate the minimal time to approach Angel. (We can move only UP, DOWN, LEFT and RIGHT, to the neighbor grid within bound, of course.) 

Input

First line contains two integers stand for N and M. 

Then N lines follows, every line has M characters. "." stands for road, "a" stands for Angel, and "r" stands for each of Angel's friend. 

Process to the end of the file. 

Output

For each test case, your program should output a single integer, standing for the minimal time needed. If such a number does no exist, you should output a line containing "Poor ANGEL has to stay in the prison all his life." 

Sample Input

7 8
#.#####.
#.a#..r.
#..#x...
..#..#.#
#...##..
.#......
........

Sample Output

13

这道题使用BFS解题思路:将每个输入看成坐标系中的一个点,然后用BFS找到最短路线。

AC代码:

#include<bits/stdc++.h>
using namespace std;
const int MAXN=200+10;
char str[MAXN][MAXN];
int vis[MAXN][MAXN];
int m,n;
struct node
{
	int x,y;
	int step;//记录步数
	friend bool operator < (node a,node b){
		return a.step>b.step; 
	}
};
int d[4][2]={{1,0},{-1,0},{0,1},{0,-1}};
void BFS(int x1,int y1,int x2,int y2)
{
	memset(vis,0,sizeof(vis));
	priority_queue<node> que;//定义优先队列
	node e1,e2;
	e1.x=x1;e1.y=y1;e1.step=0;
	que.push(e1);
	vis[x1][y1]=1;
	int ans=-1;
	while(!que.empty())
	{
		e1=que.top();
		que.pop();
		if(e1.x == x2 && e1.y == y2) {
			ans=e1.step;
			break;
		}
		for(int i=0;i<4;i++)//将当前所有可能走的路线遍历一遍
		{
			e2.x=e1.x+d[i][0];
			e2.y=e1.y+d[i][1];
			if(e2.x<0||e2.x>=n||e2.y<0||e2.y>=m) continue;
			if(vis[e2.x][e2.y]==1) continue;
			if(str[e2.x][e2.y]=='#') continue;
			if(str[e2.x][e2.y]=='x') e2.step=e1.step+2;
			else e2.step=e1.step+1;
			que.push(e2);//满足就保存在队列中
			vis[e2.x][e2.y]=1; //将该点记为1,表明已经走过,下次不需要再走;
		}
	}
	if(ans==-1)puts("Poor ANGEL has to stay in the prison all his life.");
	else printf("%d\n", ans);
 } 
int main()
{
	int edx,edy,stx,sty;
	while(scanf("%d %d",&n,&m)!=EOF)
	{
		for(int i=0;i<n;i++) 
			scanf("%s",str[i]);
		for(int i=0;i<n;i++)//记录出发点的坐标和终点坐标
			for(int j=0;j<m;j++)
			{
				if(str[i][j]=='a') stx=i,sty=j;
				if(str[i][j]=='r') edx=i,edy=j;
			}
		BFS(stx,sty,edx,edy);
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_40707370/article/details/81320159