hdu1078 FatMouse and Cheese 记忆化搜索

FatMouse and Cheese

FatMouse has stored some cheese in a city. The city can be considered as a square grid of dimension n: each grid location is labelled (p,q) where 0 <= p < n and 0 <= q < n. At each grid location Fatmouse has hid between 0 and 100 blocks of cheese in a hole. Now he's going to enjoy his favorite food. 

FatMouse begins by standing at location (0,0). He eats up the cheese where he stands and then runs either horizontally or vertically to another location. The problem is that there is a super Cat named Top Killer sitting near his hole, so each time he can run at most k locations to get into the hole before being caught by Top Killer. What is worse -- after eating up the cheese at one location, FatMouse gets fatter. So in order to gain enough energy for his next run, he has to run to a location which have more blocks of cheese than those that were at the current hole. 

Given n, k, and the number of blocks of cheese at each grid location, compute the maximum amount of cheese FatMouse can eat before being unable to move. 

Input

There are several test cases. Each test case consists of 

a line containing two integers between 1 and 100: n and k 
n lines, each with n numbers: the first line contains the number of blocks of cheese at locations (0,0) (0,1) ... (0,n-1); the next line contains the number of blocks of cheese at locations (1,0), (1,1), ... (1,n-1), and so on. 
The input ends with a pair of -1's. 

Output

For each test case output in a line the single integer giving the number of blocks of cheese collected. 

Sample Input

3 1
1 2 5
10 11 6
12 12 7
-1 -1

Sample Output

37

思路:用dp数组记录并dfs

代码:

#include<cstdio>
#include<algorithm>
#include<cstring>
#define ll long long
#define mem(a) memset(a,0,sizeof(a))
using namespace std;
const int maxn = 110;
int n,m;
int maze[maxn][maxn],dp[maxn][maxn];//dp[i][j]表示截止到位置(i,j)所存的最大和 
bool vis[maxn][maxn];
bool check(int x,int y)
{
	if (x >= n || x < 0 || y >= n || y < 0)
		return 0;
	return 1;
}
int dx[] = {1,-1,0,0};
int dy[] = {0,0,1,-1};
int ans;
int	dfs(int x,int y)
{
	int res = 0;
	if (dp[x][y]) return dp[x][y];
	for (int i = 1;i <= m;i ++)
	{
		for (int j = 0;j < 4;j ++)
		{
			int xx = x + dx[j] * i,yy = y + dy[j] * i;
			if (check(xx,yy) && maze[xx][yy] > maze[x][y])
				res = max(res,dfs(xx,yy));
			dp[x][y] = res + maze[x][y];
		}
	}
	return dp[x][y];
}
int main()
{
	while (~scanf("%d %d",&n,&m) && (n != -1 || m != -1))
	{
		for (int i = 0;i < n;i ++)
			for (int j = 0;j < n;j ++)
			{
				scanf("%d",&maze[i][j]);
				dp[i][j] = 0;
			}
		printf("%d\n",dfs(0,0));
	}
	return 0;	
}

猜你喜欢

转载自blog.csdn.net/cloudy_happy/article/details/81570919