【HDU - 1078】FatMouse and Cheese (记忆化搜索dp)

版权声明:欢迎学习我的博客,希望ACM的发展越来越好~ https://blog.csdn.net/qq_41289920/article/details/84788329

题干:

FatMouse has stored some cheese in a city. The city can be considered as a square grid of dimension n: each grid location is labelled (p,q) where 0 <= p < n and 0 <= q < n. At each grid location Fatmouse has hid between 0 and 100 blocks of cheese in a hole. Now he's going to enjoy his favorite food. 

FatMouse begins by standing at location (0,0). He eats up the cheese where he stands and then runs either horizontally or vertically to another location. The problem is that there is a super Cat named Top Killer sitting near his hole, so each time he can run at most k locations to get into the hole before being caught by Top Killer. What is worse -- after eating up the cheese at one location, FatMouse gets fatter. So in order to gain enough energy for his next run, he has to run to a location which have more blocks of cheese than those that were at the current hole. 

Given n, k, and the number of blocks of cheese at each grid location, compute the maximum amount of cheese FatMouse can eat before being unable to move. 

Input

There are several test cases. Each test case consists of 

a line containing two integers between 1 and 100: n and k 
n lines, each with n numbers: the first line contains the number of blocks of cheese at locations (0,0) (0,1) ... (0,n-1); the next line contains the number of blocks of cheese at locations (1,0), (1,1), ... (1,n-1), and so on. 
The input ends with a pair of -1's. 

Output

For each test case output in a line the single integer giving the number of blocks of cheese collected. 

Sample Input

3 1
1 2 5
10 11 6
12 12 7
-1 -1

Sample Output

37

题目大意:

有一种游戏是的玩法是这样的:
有一个n*n的格子,每个格子有一个数字。
遵循以下规则:
1. 玩家每次可以由所在格子向上下左右四个方向进行直线移动,每次移动的距离不得超过m
2. 玩家一开始在第一行第一列,并且已经获得该格子的分值
3. 玩家获得每一次移动到的格子的分值
4. 玩家下一次移动到达的格子的分值要比当前玩家所在的格子的分值要大。
5. 游戏所有数字加起来也不大,保证所有数字的和不会超过int型整数的范围
6. 玩家仅能在n*n的格子内移动,超出格子边界属于非法操作
7. 当玩家不能再次移动时,游戏结束
现在问你,玩家所能获得的最大得分是多少?

输入是n和m。

解题报告:

     水题,,但是刚开始读错题,没看到只能从(1,1)点开始游戏 这个条件,所以WA了、、

AC代码:

#include<bits/stdc++.h>
#define ll long long
using namespace std;

int nx[4] = {0,1,0,-1};
int ny[4] = {1,0,-1,0};
ll dp[105][105];
int a[105][105];

int n,m;
bool ok(int x,int y) {
	if(x>=1&&x<=n&&y>=1&&y<=n) return 1;
	else return 0;
}
ll dfs(int x,int y) {
	if(dp[x][y] != -1) return dp[x][y];
	ll res = 0;
	int tx,ty;
	for(int k = 0; k<4; k++) {
		tx = x;ty = y;
		for(int i = 1; i<=m; i++) {
			tx += nx[k];ty += ny[k];
			if(ok(tx,ty)==0) continue;
			if(a[tx][ty] <= a[x][y]) continue;
			res = max(res,dfs(tx,ty));
		}

	}
	return dp[x][y]=res+a[x][y];
	
}
int main()
{
	while(~scanf("%d%d",&n,&m)) {
		if(n==-1 && m==-1) break;
		memset(dp,-1,sizeof dp);
		ll ans = 0;
		for(int i = 1; i<=n; i++) {
			for(int j = 1; j<=n; j++) {
				scanf("%d",&a[i][j]);
			}
		}		
//		for(int i = 1; i<=n; i++) {
//			for(int j = 1; j<=n; j++) {
//				ans = max(ans,dfs(i,j));
//			}
//		}
		ans = dfs(1,1);
		printf("%lld\n",ans);
		
	} 
	return 0 ;
 } 

猜你喜欢

转载自blog.csdn.net/qq_41289920/article/details/84788329