HDU - 1078 L - FatMouse and Cheese 【经典记忆化搜索】

FatMouse has stored some cheese in a city. The city can be considered as a square grid of dimension n: each grid location is labelled (p,q) where 0 <= p < n and 0 <= q < n. At each grid location Fatmouse has hid between 0 and 100 blocks of cheese in a hole. Now he's going to enjoy his favorite food. 

FatMouse begins by standing at location (0,0). He eats up the cheese where he stands and then runs either horizontally or vertically to another location. The problem is that there is a super Cat named Top Killer sitting near his hole, so each time he can run at most k locations to get into the hole before being caught by Top Killer. What is worse -- after eating up the cheese at one location, FatMouse gets fatter. So in order to gain enough energy for his next run, he has to run to a location which have more blocks of cheese than those that were at the current hole. 

Given n, k, and the number of blocks of cheese at each grid location, compute the maximum amount of cheese FatMouse can eat before being unable to move. 

Input

There are several test cases. Each test case consists of 

a line containing two integers between 1 and 100: n and k 
n lines, each with n numbers: the first line contains the number of blocks of cheese at locations (0,0) (0,1) ... (0,n-1); the next line contains the number of blocks of cheese at locations (1,0), (1,1), ... (1,n-1), and so on. 
The input ends with a pair of -1's. 

Output

For each test case output in a line the single integer giving the number of blocks of cheese collected. 

Sample Input

3 1
1 2 5
10 11 6
12 12 7
-1 -1

Sample Output

37

code:

#include<bits/stdc++.h>
using namespace std;

int ma[105][105],dp[105][105],n,m;

int dx[]={0,0,1,-1},dy[]={1,-1,0,0};

bool check(int x,int y){
	return x>=0&&x<n&&y>=0&&y<n;
}

int dfs(int x,int y){
	int ans=ma[x][y];//返回值 在(x,y)位置至少能得到ma[x][y]的东西 
	if(dp[x][y]) return dp[x][y];
	for(int k=1;k<=m;k++){//每个方向最多 k 步  
		for(int i=0;i<3;i++){//遍历4个方向 
			int fx=x+dx[i]*k;
			int fy=y+dy[i]*k;
			if(check(fx,fy) && ma[fx][fy]>ma[x][y]){
				int temp=dfs(fx,fy)+ma[x][y];//temp记录中间值 
				ans=max(temp,ans);
			}
		}	
	}
	return dp[x][y]=ans;
}

int main(){
	while(cin>>n>>m,n!=-1 || m!=-1){
		for(int i=0;i<n;i++){
			for(int j=0;j<n;j++){
				cin>>ma[i][j];
			}
		}
		cout<<dfs(0,0)<<endl;//起点已经确定 不用再遍历寻找哪个起点能找到最大值 
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41333844/article/details/81588085
今日推荐