HDU 1061 Rightmost Digit(普通快速幂)

Problem Description

Given a positive integer N, you should output the most right digit of N^N.

Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).

Output

For each test case, you should output the rightmost digit of N^N.

Sample Input

 

2

3

4

Sample Output

扫描二维码关注公众号,回复: 2843494 查看本文章
 

7

6

Hint

In the first case, 3 * 3 * 3 = 27, so the rightmost digit is 7.

In the second case, 4 * 4 * 4 * 4 = 256, so the rightmost digit is 6.

题目大意:给出一个数a,求a的a次方的结果,输出结果的个位数字。

思路:跑一遍是不可能的,这辈子都不可能的。该题是快速幂的模板题,快速幂的时间复杂度是O(log2 N)。

快速幂模板:https://blog.csdn.net/yopilipala/article/details/68952650

原理:https://www.jianshu.com/p/1c3f88f63dec

代码如下:

#include<set>
#include<map>
#include<list>
#include<deque>
#include<cmath>
#include<queue>
#include<string>
#include<vector>
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#include<ext/rope>
#include<iostream>
#include<algorithm>
#define pi acos(-1.0)
#define INF 0x3f3f3f3f
#define per(i,a,b) for(int i=a;i<=b;++i)
#define max(a,b)  a>b?a:b
#define min(a,b)  a<b?a:b
#define swap(a,b) {int t=a;a=b;b=t} 
using namespace std;
using namespace __gnu_cxx;
const long long MOD = 10;
long long q_pow(long long int a,long long int b)
{
    long long int sum=1;
    while(b)
    {
        if(b&1)
        sum=(sum*a)%MOD;
        a=(a*a)%MOD;
        b>>=1;
    }
    return sum;
}
int main()
{
    int t,i,a;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&a);        
        printf("%d\n",q_pow(a,a));
    }
    return 0;
    
}

猜你喜欢

转载自blog.csdn.net/PleasantlY1/article/details/81674130