Rightmost Digit

Rightmost Digit

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 25852    Accepted Submission(s): 9929


Problem Description
Given a positive integer N, you should output the most right digit of N^N.
 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
 

Output
For each test case, you should output the rightmost digit of N^N.
 

Sample Input
 
  
2 3 4
 

Sample Output
 
  
7 6

#include <cstdio>


int a[10][4]={{0},{1},{6,2,4,8},{1,3,9,7},{6,4},{5},{6},{1,7,9,3},{6,8,4,2},{1,9}};
int main()
{
    int m,n;
    scanf("%d",&m);
        while(m--)
        {
            scanf("%d",&n);
            int t=n%10;
            if(t==0||t==1||t==5||t==6)
            printf("%d\n",t);
            else if(t==4||t==9)
           {
                printf("%d\n",a[t][n%2]);
           }
            else
           {printf("%d\n",a[t][n%4]);}
       }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/u011582187/article/details/10920579