Leftmost Digit

#问题:

Leftmost Digit

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3932 Accepted Submission(s): 1752
 
Problem Description
Given a positive integer N, you should output the leftmost digit of N^N.
 
Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
 
Output
For each test case, you should output the leftmost digit of N^N.
 
Sample Input
2
3
4
 
Sample Output
2
2

#即使想到了取对也半天没看出来,后来借鉴了大神的做法

#AC码

#include<iostream>
#include<math.h>
using namespace std;
int main()
{
    int t,n;
    cin>>t;
    while(t--)
    {
        cin>>n;
        double a,x;
        x=n*log10(double(n));
        a=x-floor(x);
        int ans=(int)pow(10.0,a);
        cout<<ans<<endl;

    }
}

#分析:

N^N取对得NlogN,设它等于M.N(即M+N),M是整数部分,N是小数部分。N^N=10^(NlogN)=10^(M.N)=10^(M+N)=(10^M)*(10^N),由于N属于(0,1),故10^N属于(1,10),即为N^N用科学记数法表示的基数部分,也就是对10^N取整便是需求的N^N最高位。

猜你喜欢

转载自blog.csdn.net/u014302425/article/details/80494872