hdu 1060 Leftmost Digit

Given a positive integer N, you should output the leftmost digit of N^N.
Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
Output
For each test case, you should output the leftmost digit of N^N.
Sample Input
2
3
4
Sample Output
2
2

#include <bits/stdc++.h>
using namespace std;
typedef long long ll;
const int N=1e5+7;
int main()
{
    int t;
    cin>>t;
    while(t--)
    {
        ll n;
        scanf("%lld",&n);
        double tmp=n*log10(n*1.0);
        printf("%lld\n",(ll)pow(10.0,tmp-(ll)tmp));
    }
}

猜你喜欢

转载自blog.csdn.net/oinei/article/details/79996843