HDU1597 find the nth digit【模拟】

find the nth digit

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 15975    Accepted Submission(s): 5044


 

Problem Description

假设:
S1 = 1
S2 = 12
S3 = 123
S4 = 1234
.........
S9 = 123456789
S10 = 1234567891
S11 = 12345678912
............
S18 = 123456789123456789
..................
现在我们把所有的串连接起来
S = 1121231234.......123456789123456789112345678912.........
那么你能告诉我在S串中的第N个数字是多少吗?

Input

输入首先是一个数字K,代表有K次询问。
接下来的K行每行有一个整数N(1 <= N < 2^31)。

Output

对于每个N,输出S中第N个对应的数字.

Sample Input

 

6
1
2
3
4
5
10

Sample Output

1
1
2
1
2
4

Author

8600

Source

HDU 2007-Spring Programming Contest - Warm Up (1)

问题链接:HDU1597 find the nth digit

问题描述:S1=1,S2=12,S3=123,... ,当长度大于9时就进行1-9的循环。将所有的字符串拼接起来,S1S2...Sm。给定n,问n位置的数是什么

解题思路:模拟。先确定n在哪个字符串,然后确定对应的值,具体看程序。

AC的C++程序:

#include<iostream>
#include<cstdio>
#include<algorithm>

using namespace std;

int main()
{
	int n,t;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d",&n);
		int l=1;//l表示字符串的长度,第一个字符串的长度为1 
		while(n>l)
		{
			n-=l;
			l++;//获取下一个字符串的长度 
		}
		n%=9;//获取n在此字符串的位置 
		if(n==0) n=9; //如果n=0表示n的位置为9 
		printf("%d\n",n);
	}
	return 0; 
 } 

猜你喜欢

转载自blog.csdn.net/SongBai1997/article/details/84645180