H - Leftmost Digit

H - Leftmost Digit

Given a positive integer N, you should output the leftmost digit of N^N. 
InputThe input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow. 
Each test case contains a single positive integer N(1<=N<=1,000,000,000). 
OutputFor each test case, you should output the leftmost digit of N^N. 
Sample Input
2
3
4
Sample Output
2
2


        
  
Hint
In the first case, 3 * 3 * 3 = 27, so the leftmost digit is 2.
In the second case, 4 * 4 * 4 * 4 = 256, so the leftmost digit is 2.
    思路:这个题目的话,可以说想法是很巧妙的,用的了 log 函数,加上了公式的推导,具体请看公式推导过程

     首先用科学计数法来表示    N^N  = a*10^x;  比如N = 3;  3^3 = 2.7 * 10^1;


              我们要求的最右边的数字就是(int)a,即a的整数部分;    

            

              OK, 然后两边同时取以10为底的对数     lg(N^N) = lg(a*10^x) ;


              化简                                       N*lg(N)  = lg(a) + x;


              继续化                                       N*lg(N) - x = lg(a)

                                                     a = 10^(N*lg(N) - x);

              现在就只有x是未知的了,如果能用n来表示x的话,这题就解出来了。

             又因为,x是N^N的位数。比如 N^N = 1200  ==>  x = 3;    实际上就是 x 就是 lg(N^N) 向下取整数,

           

             表

示为[lg(N^N)]

             好啦      a = 10^(N*lg(N) - [lg(N^N)]);    然后(int)a 就是答案了。 

 代码:


#include<stdio.h>
#include<string.h>
#include<math.h>
#include<algorithm>
using namespace std;
int main()
{
    int n;
    scanf("%d",&n);
    while(n--)
    {
        int a;
        scanf("%d",&a);
        double m=(double)a*log10(a);
        m-=(long long)m;
        int t=(int)pow(10,m);
        printf("%d\n",t);
    }
    return 0;
}






猜你喜欢

转载自blog.csdn.net/hnust_lec/article/details/79831581