POJ - 1142 A - Smith Numbers

While skimming his phone directory in 1982, Albert Wilansky, a mathematician of Lehigh University,noticed that the telephone number of his brother-in-law H. Smith had the following peculiar property: The sum of the digits of that number was equal to the sum of the digits of the prime factors of that number. Got it? Smith's telephone number was 493-7775. This number can be written as the product of its prime factors in the following way: 

4937775= 3*5*5*65837


The sum of all digits of the telephone number is 4+9+3+7+7+7+5= 42,and the sum of the digits of its prime factors is equally 3+5+5+6+5+8+3+7=42. Wilansky was so amazed by his discovery that he named this kind of numbers after his brother-in-law: Smith numbers. 
As this observation is also true for every prime number, Wilansky decided later that a (simple and unsophisticated) prime number is not worth being a Smith number, so he excluded them from the definition. 
Wilansky published an article about Smith numbers in the Two Year College Mathematics Journal and was able to present a whole collection of different Smith numbers: For example, 9985 is a Smith number and so is 6036. However,Wilansky was not able to find a Smith number that was larger than the telephone number of his brother-in-law. It is your task to find Smith numbers that are larger than 4937775!

Input

The input file consists of a sequence of positive integers, one integer per line. Each integer will have at most 8 digits. The input is terminated by a line containing the number 0.

Output

For every number n > 0 in the input, you are to compute the smallest Smith number which is larger than n,and print it on a line by itself. You can assume that such a number exists.

Sample Input

4937774
0

Sample Output

4937775

 解题思路:使用算数基本定理求出素因子,直接使用模板就可以了

算术基本定理:

任何一个大于1的自然数N,如果N不为质数,那么N可以分解
成有限个质数的乘积,并且在不计次序的情况下,这种分解
方式是唯一的。
例如60可以分解为:2^3 3 5

求质因子模板代码:

map <int , int > prime_factor (int n){
	for(int i = 2; i * i <= n; i ++){
		while (n % i == 0) {
			++ ans [i];
			n /= i;
		}
	}
	if(n != 1) ans [n] = 1;
	return ans ;//返回值是map容器
}

AC代码:

#include<iostream>
#include<map>
#include<cstdio>
using namespace std;
map<int,int> ans;
map <int , int > prime_factor (int n){//求质因子 
	for(int i = 2; i * i <= n; i ++){
		while (n % i == 0) {
			++ ans [i];
			n /= i;
		}
	}
	if(n != 1) ans [n] = 1;
	return ans ;
}
int sum(int n){//求n每一位数字之和 
	int b=0;
	while(n)
	{
		b+=n%10;
		n=n/10;
	}
	return b;
}
int main(){
	int n,t;
	while(cin>>n&&n)
	{
			
		for(int j=n+1;1;j++)
		{
			int k=0;
			ans.clear();
			prime_factor (j);
			map<int,int>::iterator a;
			int m=0,b=0;
			for(a=ans.begin();a!=ans.end();a++)
				{
				
					for(int i=0;i<a->second;i++)
					{
						m+=sum(a->first);	k++;
					}
					
				}
				if(k==1)continue;//因为一位素数不是smith数 
			b=sum(j);
			if(m==b&&b&&m){
				printf("%d\n",j);break;
			}
		
		}
		
	}
	
}

猜你喜欢

转载自blog.csdn.net/qq_40707370/article/details/82425184