#HDU 3631 Shortest Path (floyed 插点计算)

Problem Description

When YY was a boy and LMY was a girl, they trained for NOI (National Olympiad in Informatics) in GD team. One day, GD team’s coach, Prof. GUO asked them to solve the following shortest-path problem.
There is a weighted directed multigraph G. And there are following two operations for the weighted directed multigraph:
(1) Mark a vertex in the graph.
(2) Find the shortest-path between two vertices only through marked vertices.
For it was the first time that LMY faced such a problem, she was very nervous. At this moment, YY decided to help LMY to analyze the shortest-path problem. With the help of YY, LMY solved the problem at once, admiring YY very much. Since then, when LMY meets problems, she always calls YY to analyze the problems for her. Of course, YY is very glad to help LMY. Finally, it is known to us all, YY and LMY become programming lovers.
Could you also solve the shortest-path problem?

Input

The input consists of multiple test cases. For each test case, the first line contains three integers N, M and Q, where N is the number of vertices in the given graph, N≤300; M is the number of arcs, M≤100000; and Q is the number of operations, Q ≤100000. All vertices are number as 0, 1, 2, … , N - 1, respectively. Initially all vertices are unmarked. Each of the next M lines describes an arc by three integers (x, y, c): initial vertex (x), terminal vertex (y), and the weight of the arc (c). (c > 0) Then each of the next Q lines describes an operation, where operation “0 x” represents that vertex x is marked, and operation “1 x y” finds the length of shortest-path between x and y only through marked vertices. There is a blank line between two consecutive test cases.
End of input is indicated by a line containing N = M = Q = 0.

Output

Start each test case with "Case #:" on a single line, where # is the case number starting from 1.
For operation “0 x”, if vertex x has been marked, output “ERROR! At point x”.
For operation “1 x y”, if vertex x or vertex y isn’t marked, output “ERROR! At path x to y”; if y isn’t reachable from x through marked vertices, output “No such path”; otherwise output the length of the shortest-path. The format is showed as sample output.
There is a blank line between two consecutive test cases.

Sample Input

 

5 10 10 1 2 6335 0 4 5725 3 3 6963 4 0 8146 1 2 9962 1 0 1943 2 1 2392 4 2 154 2 2 7422 1 3 9896 0 1 0 3 0 2 0 4 0 4 0 1 1 3 3 1 1 1 0 3 0 4 0 0 0

Sample Output

 

Case 1: ERROR! At point 4 ERROR! At point 1 0 0 ERROR! At point 3 ERROR! At point 4

 题目大意 : 给出一张有n个定点,m条边的有向图,开始这些点都没有加入到图中。然后进行C次询问,输入0表示加入这个顶点,如果这个顶点U已经被加入过了,输入"ERROR! At point U", 输入1的时候,如果这两个点其中之一没有被加入,输出 “ERROR! At path U to V”, 若两点之间的距离是无穷大,则输出 “No such path”, 否则输出二者的路径。

思路 : 按照他说的去模拟就好,至于怎么加点,如果理解了floyed算法的话应该知道, 最外层的K就是用来表示能够经过该点的目前最短路, 不是最终的,但是由于题目也是一步一步加入点,所以用floyed就可以解决了。

AC代码 :

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
const int maxn = 1e3 + 5;
const int INF = 1e8;

int p[maxn][maxn], n, m, c, X;
bool vis[maxn], flag;
void init() {
    for (int i = 0; i < n; i++) {
        vis[i] = 0;
        for (int j = 0; j < n; j++) {
            if (i == j) p[i][j] = 0;
            else p[i][j] = INF;
        }
    }
}
void floyed (int k) {
    for (int i = 0; i < n; i++) {
        for (int j = 0; j < n; j++)
            p[i][j] = min (p[i][j], p[i][k] + p[k][j]);
    }
}

int main()
{
    while (scanf("%d%d%d", &n, &m, &c) && n + m + c) {
        if (flag) cout << endl;
        flag = 1;
        init();
        for (int i = 0; i < m; i++) {
            int u, v, w;
            scanf("%d%d%d", &u, &v, &w);
            p[u][v] = min (p[u][v], w);
        }
        cout << "Case " << ++X << ":" << endl;
        while (c--) {
            int ai, bi, ci;
            scanf("%d%d", &ai, &bi);
            if (!ai) {
                if (vis[bi]) cout << "ERROR! At point " << bi << endl;
                else {
                    vis[bi] = 1;
                    floyed(bi);
                }
            }
            else {
                scanf("%d", &ci);
                if (!vis[bi] || !vis[ci]) cout << "ERROR! At path " << bi << " to " << ci << endl;
                else if (p[bi][ci] < INF) cout << p[bi][ci] << endl;
                else cout << "No such path" << endl;
            }
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_43851525/article/details/91352447
今日推荐