PAT Advanced 1143 Lowest Common Ancestor (30) [二叉查找树 LCA]

题目

The lowest common ancestor (LCA) of two nodes U and V in a tree is the deepest node that has both U and V as descendants.
A binary search tree (BST) is recursively defined as a binary tree which has the following properties:

  • The lef subtree of a node contains only nodes with keys less than the node’s key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node’s key.
  • Both the lef and right subtrees must also be binary search trees.

Given any two nodes in a BST, you are supposed to find their LCA.
Input Specification:
Each input file contains one test case. For each case, the first line gives two positive integers: M (<= 1000), the number of pairs of nodes to be tested; and N (<= 10000), the number of keys in the BST, respectively. In the second line, N distinct integers are given as the preorder traversal sequence of the BST. Then M lines follow, each contains a pair of integer keys U and V. All the keys are in the range of int.
Output Specification:
For each given pair of U and V, print in a line “LCA of U and V is A.” if the LCA is found and A is the key. But if A is one of U and V, print “X is an ancestor of Y.” where X is A and Y is the other node. If U or V is not found in the BST, print in a line “ERROR: U is not found.” or “ERROR: V is not found.” or “ERROR: U and V are not found.”.
Sample Input:
6 8
6 3 1 2 5 4 8 7
2 5
8 7
1 9
12 -3
0 8
99 99
Sample Output:
LCA of 2 and 5 is 3.
8 is an ancestor of 7.
ERROR: 9 is not found.
ERROR: 12 and -3 are not found.
ERROR: 0 is not found.
ERROR: 99 and 99 are not found.

题目分析

已知二叉查找树的前序序列,求每个测试样例中两个节点最近公共祖先节点

解题思路

利用二叉查找树特点:根节点,大于左子树所有结点,小于右子树所有结点
前序序列依次遍历,即为从左到右从下到上每个根节点,判断测试样例两个节点与每个根节点大小关系

  1. u,v在root两边,则root为u,v最近公共祖先节点
  2. u,v都在root左边,则最近公共祖先在root左子树,递归查找
  3. u,v都在root右边,则最近公共祖先在root右子树,递归查找
  4. u==root,则u是v的最近公共祖先节点
  5. v==root,则v是u的最近公共祖先节点

易错点

利用前序升序排序得到中序,前序+中序查找lca会有一个测试点超时(对比A1151)

Code

#include <iostream>
#include <vector>
#include <map>
using namespace std;
map<int,bool> mp;
int main(int argc,char * argv[]) {
    int m,n,u,v,a;
    scanf("%d %d",&m,&n);
    vector<int> pre(n);
    for(int i=0; i<n; i++) {
        scanf("%d",&pre[i]);
        mp[pre[i]]=true;
    }
    for(int i=0; i<m; i++) {
        scanf("%d %d",&u,&v);
        for(int i=0; i<n; i++) {
            a=pre[i];
            if(a>=u&&a<=v||a<=u&&a>=v)break;
        }
        if(mp[u]==false&&mp[v]==false)  //都没找到
            printf("ERROR: %d and %d are not found.\n",u,v);
        else if(mp[u]==false||mp[v]==false)
            printf("ERROR: %d is not found.\n",mp[u]==false?u:v);
        else if(a==v||a==u)
            printf("%d is an ancestor of %d.\n",a,a==v?u:v);
        else
            printf("LCA of %d and %d is %d.\n",u,v,a);
    }
    return 0;
}


猜你喜欢

转载自www.cnblogs.com/houzm/p/12342842.html