PAT 1065 A+B and C (64bit) python解法

1065 A+B and C (64bit) (20 分)
Given three integers A, B and C in [−2​63​​ ,2​63​​ ], you are supposed to tell whether A+B>C.

Input Specification:
The first line of the input gives the positive number of test cases, T (≤10). Then T test cases follow, each consists of a single line containing three integers A, B and C, separated by single spaces.

Output Specification:
For each test case, output in one line Case #X: true if A+B>C, or Case #X: false otherwise, where X is the case number (starting from 1).

Sample Input:
3
1 2 3
2 3 4
9223372036854775807 -9223372036854775808 0
Sample Output:
Case #1: false
Case #2: true
Case #3: false

题意:给3个数a b c,如果a+b>c,就输出Case #i: ture,否则输出Case #i: false,其中i是第i个输入。

解题思路:
这是一个水题,尤其是对于python来说,直接判断就好了。

n = int(input())
for i in range(n):
    a,b,c=input().split()
    if int(a)+int(b)>int(c):
        print('Case #%d: true'%(i+1))
    else:
        print('Case #%d: false'%(i+1))

猜你喜欢

转载自blog.csdn.net/qq_36936510/article/details/86618346